Thread: Memory not being recognized

  1. #1

    Join Date
    May 2005

    Memory not being recognized

    Okay so I'm about to throw this thing out the window. My parents have an old K7T 266 motherboard with a 1.4 GHz Athlon processor. I just got home, and they want me to do some upgrades to make it run better. I check it out, and it only has 256 MB of ram. We buy more, I install it, and the system doesn't recognize it.

    I am simply trying to add another 256MB for 512 total, but the system only recognizes the old stick of ram. The manual that comes with my mobo offers no special instructions for installing memory (e.g. no special sequences that they must go in). The new stick of ram I bought is PC2700/PC2100, so it can run on either a 266 or 333 MHz bus speed, but the added memory is not being recognized at all.

    I've tried:
    -buying two different sticks of DDR ram
    -installed them in every possible combination alone and with the old stick
    -reading the manual
    -kicking my cat

    The old ram is simply 256MB ddr pc 2100 266MHz, and has memory modules built onto both sides. It's some generic brand, and doesn't say what it is on the stick.

    The new brand is something I quickly picked up from staples, 256MB of PC2700/PC2100 (333/266). I dont know if it is significant but it says 'DDR DT' on the package.

    I'm really not sure why this system isn't recognizing the ram, it isn't supposed to be this much of a headache.

    Any input will yield genuine affection.
    I'm not immature, I'm refined in the opposite direction.

  2. #2
    Officially An Architect brewbuck's Avatar
    Join Date
    Mar 2007
    Portland, OR
    Maybe this is obvious, but have you checked the CMOS to see if it's hard-set to 256 MB?

    EDIT: Nevermind. Upon a reread I see you already tried installing a new DIMM by itself, and it didn't work. So that idea's shot.

  3. #3

    Join Date
    May 2005
    I appreciate the reply regardless
    I'm not immature, I'm refined in the opposite direction.

  4. #4
    Registered User
    Join Date
    Oct 2001
    maybe the mb doesn't know how to play nice with the higher speed memory (or vice versa). If that is the case, a BIOS update might help.

  5. #5
    Super Moderator VirtualAce's Avatar
    Join Date
    Aug 2001
    Perhaps one of the modules cannot run at the faster speed. If this is the case the mobo will only recognize the memory at the lowest speed.

    Since there is not a specific set of instructions about which banks to put the memory in this probably means it does not matter. My old ASUS board was like this and it would accept nearly any configuration.

    My guess is the speed is the problem. I remember some time back when I bought memory that was faster than what another module could handle and had the same exact troubles you are having. The new memory for some reason is not speed-scaling down to the slower speed and thus is not being recognized.

  6. #6
    Registered User Frobozz's Avatar
    Join Date
    Dec 2002
    Except he's already tried the new one by itself. If the old memory stick was causing issues they shouldn't be present if its missing.

    Who made the system and what model is it? Also the motherboard model would help a bit too.

  7. #7
    Woof, woof! zacs7's Avatar
    Join Date
    Mar 2007
    The mobo could it not support dual-channel ram perhaps?

    Have you tried kicking your cat again? :P

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Replies: 4
    Last Post: 01-13-2008, 02:14 AM
  2. Question regarding Memory Leak
    By clegs in forum C++ Programming
    Replies: 29
    Last Post: 12-07-2007, 01:57 AM
  3. Memory problem with Borland C 3.1
    By AZ1699 in forum C Programming
    Replies: 16
    Last Post: 11-16-2007, 11:22 AM
  4. reading files into memory
    By bobthebullet990 in forum C Programming
    Replies: 3
    Last Post: 11-30-2005, 03:39 PM
  5. Shared Memory - shmget questions
    By hendler in forum C Programming
    Replies: 1
    Last Post: 11-29-2005, 02:15 AM