Thread: what program is using this file?

  1. #1

    Join Date
    May 2005

    what program is using this file?

    I downloaded a file related to an AutoCAD trial offer some time ago, but never got around to doing anything with it.

    Last week, I tried deleting it, but got the message "this file cannot be deleted it is being used by another program" etc etc...I just left it alone, thinking it'd be okay to delete some other time.

    Well, I was wrong, I tried deleting it again today but got the same message...I have absolutely no clue what program is using this file, as there doesn't appear to be anything running that even remotely relates to AutoCAD....

    How can I find out what program/process is using this file? I am upset now, I want this damn thing gone.
    I'm not immature, I'm refined in the opposite direction.

  2. #2
    Tropical Coder Darryl's Avatar
    Join Date
    Mar 2005
    Cayman Islands
    Are you using Firefox? This happens sometimes with firefox where it doesn't "clean-up" after download completes or when you stop it before it finished. I have had this problem once or twice. I use a program called moveonboot to delete it, but there are other utilities as well that can break the lock.

  3. #3
    Registered /usr
    Join Date
    Aug 2001
    Newport, South Wales, UK
    Dropping into Safe Mode usually allows you to delete them. They usually get locked by Explorer because some programmer with annoying habits likes to integrate their program component DLLs with the shell.

  4. #4
    and the Hat of Clumsiness GanglyLamb's Avatar
    Join Date
    Oct 2002
    between photons and phonons
    If deleting it in safe mode doesnt work like SMurf suggested try FileMon ( ) .

    With this tool you'll be able to see what process is using what files.

    Once the process located , you can manually kill it , and afterwards delete the file.

  5. #5
    and the hat of int overfl Salem's Avatar
    Join Date
    Aug 2001
    The edge of the known universe
    Also from sysinternals is process explorer, which has a handy search feature to find out which program still has its sticky fingers on whatever resource interests you.
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper.

  6. #6

    Join Date
    May 2005

    Thumbs up

    Moveonboot worked (I downloaded the file with firefox, I'm guessing that's what caused the problem).

    I appreciate the other replies, thanks a bunch guys
    I'm not immature, I'm refined in the opposite direction.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. File transfer- the file sometimes not full transferred
    By shu_fei86 in forum C# Programming
    Replies: 13
    Last Post: 03-13-2009, 12:44 PM
  2. gcc link external library
    By spank in forum C Programming
    Replies: 6
    Last Post: 08-08-2007, 03:44 PM
  3. Inventory records
    By jsbeckton in forum C Programming
    Replies: 23
    Last Post: 06-28-2007, 04:14 AM
  4. Post...
    By maxorator in forum C++ Programming
    Replies: 12
    Last Post: 10-11-2005, 08:39 AM
  5. My program, anyhelp
    By @licomb in forum C Programming
    Replies: 14
    Last Post: 08-14-2001, 10:04 PM