Thread: C/C++ program in EDIT PLUS

  1. #1
    Registered User
    Join Date
    Dec 2003

    Lightbulb C/C++ program in EDIT PLUS

    hi i am not able to compile my C/C++ program in edit plus.
    i use turbo c compiler. usually i run my program in DOS mode.

    but today, i downloaded editplus and set the compilers path according to editplus manual but still its not compiling and running.

    in this link i found how to set the path

    Menu text: Turbo C
    Command: c:\tc\tcc.exe
    Argument: -Ic:\tc\include -Lc:\tc\lib -n$(FileDir) $(FilePath)
    Initial directory: c:\tc
    Capture output: ON
    i changed only C:\ to D:\ . bcoz my TC compiler is in D:\
    rest of the thing i have kept same.

    so i wrote in my setting...

    Menu text: TC
    Command: d:\tc\tcc.exe
    Argument: -Id:\tc\include -Ld:\tc\lib -n$(FileDir) $(FilePath)
    Initial directory: d:\tc
    Capture output: ON

    then i clicked on tool menu TC to compile .

    i am getting a message in the output window
    "Output completed (0 sec consumed) - Cannot run the application"

    plz why program is not compiling and running. what i have to do???

    is there anyother command except tcc.exe which can compile. bcoz i did not find tcc.exe in my BIN folder

    but i run my prog in DOS mode like d:\tc\bin\tc---->then i get a blue window.. here i write program , compile and run.

    i have also changed tcc.exe to tc only but no result

  2. #2
    Registered User Draco's Avatar
    Join Date
    Apr 2002
    Argument: -Id:\tc\include -Ld:\tc\lib -n$(FileDir) $(FilePath)
    The (filedir) and (FilePath) are included as examples of what to type in, not what you type in exactly.
    if the file you want to compile is for example named project.cpp in a folder called myprojects you would type in
    -n$project.cpp $C:\myprojects

  3. #3
    Registered User
    Join Date
    Dec 2003
    hi draco

    yes my file name is link.c and i have stored it in d:\

    so i typed again:

     Argument: -Id:\tc\include -Ld:\tc\lib -n$link.c $d:\
    but its giving the same message " Output completed (0 sec consumed) - Cannot run the application "

  4. #4
    and the hat of int overfl Salem's Avatar
    Join Date
    Aug 2001
    The edge of the known universe
    This is probably a PATH issue - like tc is not in the PATH environment variable seen by editplus.
    If you think you've changed the PATH, you need to reboot / restart editplus to make the change within editplus itself.

    Also, this question is best asked on either the tech board here, or better still on the message board / mailing list of the editor in question (we're not all experts in every single editor in the world)
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper.

  5. #5
    Cat without Hat CornedBee's Avatar
    Join Date
    Apr 2003
    Originally posted by Draco
    The (filedir) and (FilePath) are included as examples of what to type in, not what you type in exactly.[/code]
    No, actually those are variables that are substituted automatically by the EditPlus tool system for the directory and full path of the current file, respectivly.
    All the buzzt!

    "There is not now, nor has there ever been, nor will there ever be, any programming language in which it is the least bit difficult to write bad code."
    - Flon's Law

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. a phone book program
    By mackieinva in forum C Programming
    Replies: 2
    Last Post: 09-19-2007, 06:31 AM
  2. Using variables in system()
    By Afro in forum C Programming
    Replies: 8
    Last Post: 07-03-2007, 12:27 PM
  3. Replies: 3
    Last Post: 07-23-2005, 08:00 AM
  4. Extracting Data From Another Program
    By (TNT) in forum Windows Programming
    Replies: 3
    Last Post: 02-12-2002, 01:25 AM