Trying to setup a VPN server and connect to it, but not having much luck. Pretty sure it's because I have one of the network settings wrong, especially since I tried a 3rd party VPN client and it told me "wrong remote address". I have replaced actual external IP addresses for my own safety.

On the remote router that is the VPN server:
Internal IP address:
External IP address: [modem]
(on the VPN settings page):
"Address Remote Network":
"Address Local Network":
Local 1:1 NAT is unchecked

Office's setup:
Our router address:
External IP address: [office]
My computer's IP address:

VPN client setup:
VPN client address:
Address type: subnet address
Remote LAN address:
Subnet mask:

When I try to connect, it passes Phase 1 auth, but hangs at Phase 2. Here is the troublesome line from the router log:

Oct 11 11:30:12 pluto[1405]: "vpn1"[2] [office]:4500 #1: cannot respond to IPsec SA request because no connection is known for[modem]:4500...[office]:4500[]===

Like I said, the VPN client says: "Wrong Remote Address". I've tried changing the Remote LAN address to just about everything.

Seriously, just beyond confused right now. And ........ed. Any help would be appreciated.