This worked the first time, but I made a few chagnes to the code and the new program didn't reflect the changes, so I tried clicking "Clean Project" and now each time I try to build the project I get the message
**** Build of configuration Default for project FirstTry ****

make all 
g++ -c -g main.cpp
g++ -g -o hello main.o
h:/mingw/bin/../lib/gcc/mingw32/4.5.0/../../../../mingw32/bin/ld.exe: cannot open output file hello.exe: Permission denied
collect2: ld returned 1 exit status
make: *** [hello.exe] Error 1
 * main.cpp
 *  Created on: 2010-10-14
 *      Author: Laforge

#include <iostream>
using namespace std;

int main () {
    // Say Begin! six times
    for (int index = 0; index < 6; ++index)
      cout << "Begin!" << endl;
    char input = 'i';
    int counter = 1;
    cout << "To exit, press 'n'" << endl;
    while(input != 'n') {
        cin  >> input;
        cout << "You just entered " << input
             << " you need to enter n to exit."
             << " this is iteration " << counter << endl;
    return 0;
all: hello.exe

	rm main.o hello.exe

hello.exe: main.o
	g++ -g -o hello main.o
	g++ -c -g main.cpp
Not sure if this is relevant but I use to get the message something like "make all: nothing to build".