Thread: library/linking question - linux(ubuntu) specific

  1. #1
    Registered User Stonehambey's Avatar
    Join Date
    Jan 2008
    Kent, UK

    Smile library/linking question - linux(ubuntu) specific

    Hmm, I wasn't sure where to put this, I thought this might be the best place

    I installed wxWidgets using apt-get install then compiled an app using the command line adding

    `wx-config --cxxflags` `wx-config --libs`
    at the end of the command. It worked fine.

    I installed allegro the same way, in fact I followed this tutorial, and I get the following error msg

    g++: allegro-config --libs: No such file or directory
    Now I had a look in /usr/include and I can see SDL, GL, and wx sitting there, and all programs using those APIs are happily compiling, so what am I missing for allegro? I did a fair amount of googling, and even tried a manual install, but no luck. I'm still a linux n00b so I'm only really going by what I can find on the internet, which isn't much when it comes to allegro

    Any help would be much appreciated,


  2. #2
    Kernel hacker
    Join Date
    Jul 2007
    Farncombe, Surrey, England
    You have missed the back-quotes (`) that you need around the script/program that gives you the option sets/libs.

    Compilers can produce warnings - make the compiler programmers happy: Use them!
    Please don't PM me for help - and no, I don't do help over instant messengers.

  3. #3
    Registered User Stonehambey's Avatar
    Join Date
    Jan 2008
    Kent, UK


    ah thanks, it appears to have fixed the problem. I thought they were just normal ' characters

    When I run this program from the command line (./alleg), it fills the whole screen, however when I double click on the app in the GUI file browser, the program is the correct size. Do you know of any reason this might be?

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. another do while question
    By kbpsu in forum C++ Programming
    Replies: 3
    Last Post: 03-23-2009, 12:14 PM
  2. Question...
    By TechWins in forum A Brief History of
    Replies: 16
    Last Post: 07-28-2003, 09:47 PM
  3. opengl DC question
    By SAMSAM in forum Game Programming
    Replies: 6
    Last Post: 02-26-2003, 09:22 PM
  4. Very simple question, problem in my Code.
    By Vber in forum C Programming
    Replies: 7
    Last Post: 11-16-2002, 03:57 PM
  5. Accessing a Specific Text Line Inside CEditView :: MFC
    By kuphryn in forum Windows Programming
    Replies: 2
    Last Post: 04-14-2002, 08:12 PM