Search:

Type: Posts; User: awsdert

Page 1 of 20 1 2 3 4

Search: Search took 0.01 seconds.

  1. Replies
    102
    Views
    2,286

    K, there was a bug but I've fixed that now, I...

    K, there was a bug but I've fixed that now, I gotta head off to work now, I also have work 2mw so won't be doing any fixes or searching for bugs until after work 2mw. In the off chance someone feels...
  2. Replies
    102
    Views
    2,286

    Gonna get ready for work then start working on...

    Gonna get ready for work then start working on integer to float conversion, in the meantime if anyone feels like looking for bugs in my float to integer conversion, here's the function:


    int...
  3. Replies
    102
    Views
    2,286

    Welp, resolved that error just now, I don't have...

    Welp, resolved that error just now, I don't have any serious ideas regarding hamster_nz's compile issues so I'll leave that on the back burner, time to go back to alu_reg_mov() and finish the float...
  4. Replies
    102
    Views
    2,286

    Gonna go to bed, thought I'd post my current...

    Gonna go to bed, thought I'd post my current problem to see if any suggestions or fixes are posted by the time I get up in the morning. All math functions seem to be working fine, added some checks...
  5. Replies
    102
    Views
    2,286

    Found the source of the error, seems when I added...

    Found the source of the error, seems when I added a node in modify() for TMP I forgot to tell alu_get_reg_nodes() the new array size so TMP was initiated with the value 0, rectified along with a bug...
  6. Replies
    102
    Views
    2,286

    Ah so that'll be why we end up with lot's a posts...

    Ah so that'll be why we end up with lot's a posts before we get communication, btw again you're assuming val is the result, val is NOT the result, num is the result, switched out my seg.from >...
  7. Replies
    102
    Views
    2,286

    That... I honestly have no idea why it is...

    That... I honestly have no idea why it is happening, at 1st I though it was a missing #endif but then that would cause my compiles to fail as well, it would even cause that different compile command...
  8. Replies
    102
    Views
    2,286

    I added that to the tests but I've seen no...

    I added that to the tests but I've seen no failures in it despite the test iterating through every bit each segment would have, however I have just noticed a subtle bug there so I will rectify that...
  9. Replies
    102
    Views
    2,286

    Wow, either you burning the midnight oil or we...

    Wow, either you burning the midnight oil or we live in vastly different timezones, GMT+0 (London) here, anyways I'll start with this post

    Nice catch, it also means there's another bug in which rem...
  10. Replies
    102
    Views
    2,286

    Turned out I hadn't resolved it, still getting...

    Turned out I hadn't resolved it, still getting errors, decided to step up my checks into loops iterating through the bit count of a segment, ended up with an error earlier in the tests, but this...
  11. Replies
    102
    Views
    2,286

    Seemed to have resolved it, seems the cause was a...

    Seemed to have resolved it, seems the cause was a left over hack, removed it now
  12. Replies
    102
    Views
    2,286

    It seems your copy of unic is out of date which...

    It seems your copy of unic is out of date which means my code for auto-updating that in the makefile is faulty, I'm gonna take a look at that but for now try deleting unic from your directory and let...
  13. Replies
    102
    Views
    2,286

    Getting a strange difference in behavior when I...

    Getting a strange difference in behavior when I run 'make check' vs 'make check run', 'make check' gives me expected behavior but the other when ends in a fault at division despite using the same...
  14. Replies
    102
    Views
    2,286

    Just to be sure, laserlight is this what you...

    Just to be sure, laserlight is this what you meant?
    alu/check_alu.c at master * awsdert/alu * GitHub
  15. Replies
    102
    Views
    2,286

    Ok, now that all those bugs have been sorted I've...

    Ok, now that all those bugs have been sorted I've gone back to the alu_reg_mov() function to do more of the float to integer step (also rectified a few bugs I noticed there), I've dealt with the...
  16. Replies
    102
    Views
    2,286

    Okay I've narrowed down the source of my broken...

    Okay I've narrowed down the source of my broken math, turns out somehow alu_reg_mov() is not seeing the data:


    make run
    cd ../ && make --no-print-directory run
    #MAKECMDGOALS=run
    cd mak && make...
  17. Replies
    102
    Views
    2,286

    Found the mistake, didn't stick a - character...

    Found the mistake, didn't stick a - character before rpath

    Edit: Someone mind looking at main.mak to find out why my objects keep getting remove after they've been built (I understand before being...
  18. Replies
    102
    Views
    2,286

    After removing the rpath flag and tweaking the...

    After removing the rpath flag and tweaking the run commands a little I found all compiles fine, it's just the system won't launch without the rpath, I must've done something wrong when shifting the...
  19. Replies
    102
    Views
    2,286

    That lookup error is a curious one, I'll get back...

    That lookup error is a curious one, I'll get back to that as soon as I see make actually find the app

    Edit: Well I tied adding in the dependencies but still having problems


    make rebuild
    cd...
  20. Replies
    102
    Views
    2,286

    That's only because git ignores empty directories...

    That's only because git ignores empty directories but I should've added the target that makes those directories so I'll rectify that now
  21. Replies
    102
    Views
    2,286

    I see no-one's thought of any suggestions as yet,...

    I see no-one's thought of any suggestions as yet, well since I'm out of ideas myself I'll just quit for the night and try again tomorrow, with any luck there'll be at least one suggestion by that...
  22. Replies
    102
    Views
    2,286

    Figured it out, I missed the directory path for...

    Figured it out, I missed the directory path for the executable object dependency, hitting a different issue now:


    make rebuild
    cd ../ && make --no-print-directory rebuild
    #MAKECMDGOALS=rebuild...
  23. Replies
    102
    Views
    2,286

    1st to that PS of yours, that was likely because...

    1st to that PS of yours, that was likely because I was making a bunch of changes to the 3rd party library I'm utilizing for it (what was named fbstdc is now named unic with all macros prepended with...
  24. Replies
    102
    Views
    2,286

    Never mind, found the reason, forgot to add /...

    Never mind, found the reason, forgot to add / after the directory macros
  25. Replies
    102
    Views
    2,286

    Encountered an issue when trying to align ALU...

    Encountered an issue when trying to align ALU with the directory setup the check tutorial is centered around, I made all the changes I can think to the makefiles but make still has a problem finding...
Results 1 to 25 of 500
Page 1 of 20 1 2 3 4