Thread: Port formwarding: connecting with the router config page

  1. #1
    Registered User
    Join Date
    Mar 2005

    Port forwarding: connecting with the router config page

    Hello, I'm trying to setup a simple test webserver on my pc, but I have a big problem: I'm not able to acces to the router configuration page for the port forwarding. Let me explain what I have been doing since now:

    I have a NoIp free domain, accepted and signed up; and the router is a Zyxel Prestige 643 (the pc o.s. is Windows XP Pro.Ed.).

    Also I have been reading some threads in here (CProgramming) (well, also in other boards) and I have been searching on the net for some manuals to port forwarding this router; finally I've found something interesting to access the config page of Zyxel P.643 (the url is

    -from command prompt open Telnet and connect to or
    -I should have an static IP adress

    Well, I try to connect to those addresses from Telnet, from Netscape and from IE but the result is long wait and finally a 'Document contains no data'. So I have to think that the problem is that I haven't a static IP address... Well, I have followed the link on the top of that manual and arribed at a manual to set up a static IP address for my o.s. (windows xp): open the control panel -> network connections -> properties -> in general tab select Internet Protocol (TCP/IP) and click the Properties button. Tha manual to setup a static IP addres says that if I do not have a dot on 'Obtain an IP adress automatically', my connection is already setup for a static IP address. So I already have a static IP adrress because I have a dot on the 'Use the following IP address' (and all the fields filled up), but I still cannot connect to the router config page.

    Finally I have tryed something else: on the manual about setup a static IP address there's a form with 2 fields: the computer default gateway and the computer current IP address; that form calcules several static IP address; so I do it and I changed my previous IP address with one of the new ones, accept the change, close all windows, test with the browser that I still have access to the net and try another time to connect to or, but still the same result. Finally I resetup the IP address with the previous one and started a new thread in CP asking for help

    I don't know what else to do. Can anyone point me in a right way?

    Thank's in advance

    P.S. Sorry for the boring explanations
    Last edited by Niara; 12-26-2006 at 01:59 PM.

  2. #2
    int x = *((int *) NULL); Cactus_Hugger's Avatar
    Join Date
    Jul 2003
    Banks of the River Styx
    What error(s) does telnet give when you try to connect?

    In the meantime, if you want to test your webserver, you should be able to connect to http://localhost/. (With the webserver running.)
    long time; /* know C? */
    Unprecedented performance: Nothing ever ran this slow before.
    Any sufficiently advanced bug is indistinguishable from a feature.
    Real Programmers confuse Halloween and Christmas, because dec 25 == oct 31.
    The best way to accelerate an IBM is at 9.8 m/s/s.
    recursion (re - cur' - zhun) n. 1. (see recursion)

  3. #3
    Hurry Slowly vart's Avatar
    Join Date
    Oct 2006
    Rishon LeZion, Israel
    1. use ipconfig to check your local IP
    2. If you should connect to 192.168.x.1 you should set you local IP to something like: and use the network Mask (this can be done in the dialog where you cheked manual/automatic IP selection)

    3. use ping to check that the destination IP address exests and is available
    4. if not - check your second possible address.
    5. If both fail - try to reset your router aand try againg
    6 after pinging is successful - use the found address for telnet connection
    All problems in computer science can be solved by another level of indirection,
    except for the problem of too many layers of indirection.
    David J. Wheeler

  4. #4
    Registered User
    Join Date
    Mar 2005
    Hello both, thank's for your time and help. Finally it works. The problem was that I was using that default/sample IP address to connect to the router, while the default gateway was another. On the manual appears that Zyxel P643 uses as default or, so I was using those values to connect.

    Cactus_Hugger: the telnet error information was "Can't connect to host, on port 23 : error on connection". Also I'm able able to say why of that error . And yes, I know that I can test servers on localhost, and that's what I have been doing while the implementation (hey, that's only a test server, nothing important and, of course, nothing to sell).

    vart: while the tests I have used 'ipconfig /all' to check the IP but I might have my brain on christmas holyday. The ipconfig says that my IP is and default gateway, and previously know that because on the network connections properties appears the same, but I didn't realized that the values from the manual were different.

    one more time: thanks both, now I can go on with my task.


Popular pages Recent additions subscribe to a feed

Similar Threads

  1. FTP program
    By jakemott in forum Linux Programming
    Replies: 14
    Last Post: 10-06-2008, 01:58 PM
  2. connecting to server with wrong port
    By liri in forum Networking/Device Communication
    Replies: 3
    Last Post: 11-13-2007, 03:52 AM
  3. brace-enclosed error
    By jdc18 in forum C++ Programming
    Replies: 53
    Last Post: 05-03-2007, 05:49 PM
  4. Damn router
    By RoD in forum Tech Board
    Replies: 7
    Last Post: 05-04-2004, 02:27 PM
  5. Connecting to COM port
    By Unimatrix139 in forum A Brief History of
    Replies: 1
    Last Post: 07-25-2002, 11:00 AM