I've been making OpenGL programs for a while now using GLFW, without problem, but recently every time I have tried to start a program, the application crashes during the glfwOpenWindow phase. I've tried programs that were made under windows, same problem, under glut, same problem, all during the window initialization phase.

Now I know that the problem started after I updated my Catalyst Drivers for ATI (I have a radeon X1950 Pro) but I've been contacting their support center and they just spouted gibberish at me. I've told them the problem, they recommend I remove all usb products, they tell me to create a report, I do so, I get returned some off the book cookie cutter nonsense. I try to explain to them the segementation fault, they give me garbage about how that's microsoft's problem. I just told them that the problem started when I upgraded my drivers, hope they listen.

I've tried rolling back my drivers, as the last time this happened it worked, but that was when I had 7.6 installed, now that I installed 7.7, clean installing to the ol' reliable 7.5 drivers no longer works. Funny thing, when I don't have any drivers installed, my applications run fine (microsoft's problem are you sure)

I'm at my last rope, I'm trying to find as many specialty places to post this on with no luck. Does anyone know what I am to do? Here's what my applications look like after I run them. The second one is the dubugger call stack where the error occurred.