Thanks for the help, I'm starting to get it. And by the way I just coppied the code from the tutorial. \/

BTW, some notes on programming style I noticed:
- I've almost always seen code comments appear above the line that it's talking about, not below it. So your comments might appear a bit weird to most people.
- These days most people use mixed case for function & variable names. They usually begin each word with a capital letter. (ex. SetSpeed(), ReadSpeed()...) It just makes it easier to read.
- It's a good idea to prefix your class member variables with something to make them stand out from regular function variable names. Many people like to use a "m_" prefix to mean "member variable" (ex. m_ProcessorSpeed). This way, when you're reading a large piece of code, and you see a variable that starts with m_, you immediately know it's defined in the class, not in the function, and that changing its value will affect the whole object's state.