I agree with that.
My declaration now looks like this:
Code:
void showStuff(string s, int i);
void showStuff(string t, double d);
and my definition:
Code:
void CWanderer::showStuff(string s, int i)
{	

	cout << s << i << endl;
}

void CWanderer::showStuff(string t, double d)
{
	cout << t << d << endl;
}
finally, I call it the same as before, only passing a literal double value directly into the second parameter.

I think I almost learn more directly from these forums than I do in class.