Thread: NewB with C++ - Functions & Classes

  1. #16
    Join Date
    Mar 2005
    >> It's kind of difficult to get the right bits of information, especially when several sites tell me varying things about how to get SDL to work.

    Well Im going to add to that list you have..

    This is where I got the tutorials when I started.. he has not updated for a while but there are 4 or 5 tuts there that will get you clear up to making a side scrolling shooter... I dont know if this stuff even compiles with the newer versions of SDL, I know there have been some changes recently.. it would however be well worth a shot, as he has clear examples and explanations and wrote the code well enough also..

    also you cant go wrong digging around the docs on the sdl site..

  2. #17
    Registered User Rider's Avatar
    Join Date
    Nov 2005
    I have set it up exactly as posted before (a couple of times) and added the stuff to my project's parameters tab, but it still tells me that it can't find lSDLmain

    all the lib files in the Dev-cpp\lib folder
    all the .h files in the Dev-cpp\include folder

    though the <SDL\SDL.h> thing did work exactly as it's supposed to, compiling still won't work...

  3. #18
    Registered User Rider's Avatar
    Join Date
    Nov 2005
    I have now tried to point to the .a and .lib files manually in parameters, but then I get a whole bunch of errors before even the first line of code.

     C:\DevTools\Dev-Cpp\lib\libSDL.a(SDL_systimer.o)(.text+0x15) In function `SDL_StartTicks':
      [Linker error] undefined reference to `timeBeginPeriod@4' 
      [Linker error] undefined reference to `timeGetTime@0' 
     C:\DevTools\Dev-Cpp\lib\libSDL.a(SDL_systimer.o)(.text+0xc1) In function `SDL_GetTicks': 
      [Linker error] undefined reference to `timeGetTime@0'
    and the list goes on.

    I'd just like to get this thing running so I can do some coding

    any help is appreciated

  4. #19
    Frequently Quite Prolix dwks's Avatar
    Join Date
    Apr 2005
    I've moved the DLL's to my new project's directory (My documents\Code 'n such\Tutorials\Tstprj)
    I thought there was only one DLL. SDL.DLL (which I put in the path).

    Did you add the libraries to the project options?

    Seek and ye shall find. quaere et invenies.

    "Simplicity does not precede complexity, but follows it." -- Alan Perlis
    "Testing can only prove the presence of bugs, not their absence." -- Edsger Dijkstra
    "The only real mistake is the one from which we learn nothing." -- John Powell

    Other boards: DaniWeb, TPS
    Unofficial Wiki FAQ:

    My website:
    Projects: codeform, xuni, atlantis, nort, etc.

  5. #20
    Registered User Rider's Avatar
    Join Date
    Nov 2005
    Well I found out something stupid and fixed it, I forgot to add the library directories to the "directories" tab in my project...

    that fixed most of my anguish, but now I'm getting a Makefile error...

    Compile Log:
    Executing  make...
    mingw32-make -f "C:\Documents and Settings\Administrator\My Documents\
    Code and such\Tutorials\Tstprj\" all
    mingw32-make: Nothing to be done for `all'.
    Execution terminated
    I really appreciate all the help so far... I'd just like to get this all done

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Array of classes?
    By dream_noir in forum C++ Programming
    Replies: 2
    Last Post: 03-22-2009, 11:43 AM
  2. Replies: 7
    Last Post: 11-17-2008, 01:00 PM
  3. Beginner Classes Question
    By kbro3 in forum C++ Programming
    Replies: 9
    Last Post: 08-14-2008, 07:43 AM
  4. Classes and member functions
    By uraliss in forum C++ Programming
    Replies: 2
    Last Post: 04-13-2006, 07:38 AM
  5. im extreamly new help
    By rigo305 in forum C++ Programming
    Replies: 27
    Last Post: 04-23-2004, 11:22 PM