Thread: /Gm' and '/clr' command-line options are incompatible

  1. #1
    Registered User
    Join Date
    Sep 2005

    /Gm' and '/clr' command-line options are incompatible

    cl : Command line error D2016 : '/Gm' and '/clr' command-line options are incompatible

    That is the error I get when I compile my program. The code is this(get it from msdn to test):

    #include "stdafx.h"
    #using <mscorlib.dll>
    #using <System.dll>
    using namespace System;
    using namespace System::IO;
    using namespace System::Net;
    using namespace System::Net::Sockets;
    using namespace System::Text;
    void main() {    
        try {
            // Set the TcpListener on port 13000.
            Int32 port = 13000;
            IPAddress* localAddr = IPAddress::Parse(S"");
            // TcpListener* server = new TcpListener(port);
            TcpListener* server = new TcpListener(localAddr, port);
            // Start listening for client requests.
            // Buffer for reading data
            Byte bytes[] = new Byte[256];
            String* data = 0;
            // Enter the listening loop.
            while (true) {
                Console::Write(S"Waiting for a connection... ");
                // Perform a blocking call to accept requests.
                // You could also user server.AcceptSocket() here.
                TcpClient* client = server->AcceptTcpClient();            
                data = 0;
                // Get a stream Object* for reading and writing
                NetworkStream* stream = client->GetStream();
                Int32 i;
                // Loop to receive all the data sent by the client.
                while (i = stream->Read(bytes, 0, bytes->Length)) {   
                    // Translate data bytes to a ASCII String*.
                    data = Text::Encoding::ASCII->GetString(bytes, 0, i);
                    Console::WriteLine(String::Format(S"Received: {0}", data));
                    // Process the data sent by the client.
                    data = data->ToUpper();
                    Byte msg[] = Text::Encoding::ASCII->GetBytes(data);
                    // Send back a response.
                    stream->Write(msg, 0, msg->Length);
                    Console::WriteLine(String::Format(S"Sent: {0}", data));            
                // Shutdown and end connection
        } catch (SocketException* e) {
            Console::WriteLine(S"SocketException: {0}", e);
        Console::WriteLine(S"\nHit enter to continue...");
    	return 0;
    What can I do to solve it so the program will compile?

    I'm coding in c++ and compile and code in Microsoft Visual Studio .NET 2003
    Last edited by Nark; 09-11-2005 at 05:14 PM.

  2. #2
    Registered User
    Join Date
    Sep 2005
    I fixed it suddenly(tried it 2 times before didn't work then but works now) change in the project properties->C/C++->Code Generation->Enable minimal rebuild->no

    No I have another error but I think I now know how to fix them

Popular pages Recent additions subscribe to a feed