Well I don't know - what are you doing
> void toUpperCase(char *, char *);
This should have only one parameter, not two
Then you would call it twice, like so
I see you're trying to use the Hungarian naming convention by putting various letters in front of the names. Unfortunately, you've got it wrong, so its not helping you, and might actually be hindering you.
> case "ONE":
No - this doesn't work
I don't know what you're trying to achieve here.
I think you'd be better if the code went something like....
and you removed all the switch/case statements.
if (strcmp( pNumberStringPtr, "ONE" ) == 0 )
if (strcmp( pNumberStringPtr, "TWO" ) == 0 )
if (strcmp( pNumberStringPtr, "THREE" ) == 0 )
> strcmp( pNumberStringPtr, "ONE" ) = 0
This is also wrong, you should have == for comparision, this is an assignment (a bad one at that)