Thread: Help compiling i2c-bridge.0.01

  1. #1
    Registered User
    Join Date
    Oct 2009

    Help compiling i2c-bridge.0.01

    I am trying to compile the projects found here
    USB-I2C/SPI/GPIO Interface Adapter.

    I downloaded the i2c_bridge-0.0.1-rc2.tgz package. I installed libusb and that seemed to go well with no issues. I go into the i2c_bridge-0.0.1-rc2/ directory and make. That compiles. I move into the i2c_bridge-0.0.1-rc2/i2c folder and make. It compiles and gives me ./i2c. However, when I run it, it says "error while loading shared libraries: cannot open shared object file: No such file or directory"

    The makefile in i2c i2c_bridge-0.0.1-rc2/i2c has the library directory as "../". The is in this directory. Help compiling i2c-bridge.0.01-screenshot-jpg

    If I sudo ./i2c, it still gives me the problem.

    I had to take away the -Werror and -noWdecrepated (spelling?) options in all the makefiles to get them to compile, but that shouldn't affect this should it?

    I tried copying the .so into /usr/local/lib/, but that did not help the issue. If anyone can help me find out what is wrong I would be very grateful.

  2. #2
    Registered User
    Join Date
    Dec 2006
    Did you run ldconfig after installing the library?

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Conspiracy theorists - now it's a bridge
    By VirtualAce in forum A Brief History of
    Replies: 16
    Last Post: 08-24-2007, 11:01 PM
  2. Bridge Pattern
    By curlious in forum A Brief History of
    Replies: 4
    Last Post: 12-11-2004, 10:35 PM
  3. Bridge.dll
    By sean in forum Tech Board
    Replies: 4
    Last Post: 05-23-2004, 09:52 PM
  4. Bridge Card Game
    By IneedHelp in forum C++ Programming
    Replies: 0
    Last Post: 02-09-2003, 06:32 PM
  5. The bridge
    By Malcar Morab in forum A Brief History of
    Replies: 14
    Last Post: 01-08-2003, 04:09 AM