I downloaded it when you first posted about it.
Here are my comments (from what I remember)
- You use ALOT of nesting. You nest 2-3 if() structures within other if() structures which are a part of a while() structure. This can be hard to follow and I suggest you re-think some of your logic and try using switch statements
- No goto statements.. Violate the practice of structured programming
- You have a lot of numbers in your code (no duh), but you should try a #define some constants to make the code more readable
- Your source is pretty long, you could/should break it up into multiple source files (this will help readability as well)
You did a good job, but you could clean up your code a bit. I would love to see your revised code so maybe I could learn how you did your menu.