Here is a way:
so you can call Fun() instead of myFun(). Fun() will be like a function to initialize myFun(), your original function.
char *string = "Overwritten Value";
I don't think there is another way. Well, maybe a macro could do the trick. Like:
so when you write myFun() it will be replaced with myFun(""), with "" as the dummy string.
#define myFun() myFun("");
Which is "better"? The first is more readable, the second might be more efficient, depending on your function
EDIT: But of course optional parameter seems much better (didn't know it existed)