PDA

View Full Version : Gvim stopped auto indenting



ICool
09-23-2007, 11:10 PM
All of a sudden it will not auto indent , and I didn't make any changes to settings . ANyone know how to fix this ? ( I am using the windows version 7.1 )

Salem
09-24-2007, 12:13 AM
What about a completely new source file, in another directory.
Is that similarly affected?

dwks
09-26-2007, 12:19 PM
For example, the command set autoindent, you can type :set autoindent or :set ai. To unset it, you can type :set noautoindent or :set noai.
From http://www.eng.hawaii.edu/Tutor/vi.html#settings

You could put that into your configuration file.

I don't know why it would stop in the first place, though. Did you start using a different filename extension? Perhaps it only autoindents for .c files and not .txt files or something.