PDA

View Full Version : Signature Image - 'Invalid File'



Tonto
04-08-2007, 05:30 PM
I am trying to set an image to my signature that points to an external url image file that is located here.

http://tonto.ulmb.com/img.jpg

It is an image created by libgd and is constantly updated, and will always be 500 x 90 px and ~15 Kb. I can lessen these params even further, but it is no use, and I always recieve this 'invalid file' problem from my signature.

Does anyone know why this could be happening?

Invision Forums allow the image, but this vBulletin is a little stubborn.

Cactus_Hugger
04-08-2007, 06:26 PM
The link you've posted isn't an image. What's returned is an HTML file, with a google ad, your image, and another google ad. (The image bears the same URL, which is stupid design by whomever hosts your site.)

My first guess is that since my view (and CBoards) doesn't send a referer in the HTTP headers, they get the HTML page. When a browser requests the image in that HTML page, it'll send the referer, and get the actual image.

Edit: Yup to the above. If I say:

wget http://tonto.ulmb.com/img.jpgI get an HTML page. If I use:

wget "--header=Referer: http://tonto.ulmb.com/img.jpg" http://tonto.ulmb.com/img.jpgI get the image. Not sure why Invision picks up on this trickery though.

Tonto
04-08-2007, 06:49 PM
Whoa, wierd. Only like 1/2 and hour ago it was not doing that, now I do have ads, and now it is b0rked with invision also. So I don't know now, I just wanna very simple host, where I can have a CGI file uploading script, and without ads on the images. I've gone through like 4 hosts now (t35, dajoob, hostultra, ultimatemb), and it's just all flakin' out.

Queatrix
04-11-2007, 10:04 AM
http://www.free-webhosts.com/free-cgi-web-hosting.php

Tonto
04-16-2007, 10:32 PM
Thxx