PDA

View Full Version : Permanently disable a service?



Govtcheez
05-04-2006, 08:46 AM
Quick (dumb) question - I've got a program I need to run here at work, and it doesn't work unless I disable a specific service. Frequently, after I change the service to disabled, it's restarted when I restart the computer. Is there any way to prevent this from happening?

SlyMaelstrom
05-04-2006, 09:02 AM
START > Run > msconfig > Services Tab > Uncheck the Service

This assumes Windows, of course. ;)

Govtcheez
05-04-2006, 09:52 AM
Yes, I'm on Windows.

Is that method different than using the computer management screen to disable it?

SlyMaelstrom
05-04-2006, 09:58 AM
Is that method different than using the computer management screen to disable it?

You mean the Task Manager (CTRL-ALT-DEL)?

Yes, it is. The Task Manager lists the processes currently running. You can disable them, but it only disables them until the computer is rebooted. The System Configuration Utility(msconfig) lists the Services that boot on Start Up. Disabling them will disable them permanently until they are reenabled by the user.

Be careful, of course, of what you disable because Windows will let you disable necessary startup services.

Govtcheez
05-04-2006, 10:38 AM
> You mean the Task Manager (CTRL-ALT-DEL)?

No, as in right clicking on My Computer and selecting "Manage".

For whatever reason, msconfig doesn't work on either of the PCs I tried it on. Is that included with Win 2K?

SlyMaelstrom
05-04-2006, 11:19 AM
Ah Win2k... that's actually the one out of the blue version that doesn't have MSCONFIG.

Check this out: http://www.mlin.net/StartupCPL.shtml

It's a psudo MSCONFIG that can be used in Windows 2000. I don't know about the manage app as I don't know Windows 2000, well.

Ken Fitlike
05-04-2006, 11:59 AM
Don't use msconfig for win2k/xp, use services.msc - you can use the 'run' command or launch it from control panel --> administrative tools. Then just set the offending service to whatever you want (disable, probably) - that's a right-click-->properties; it's easy enough to fiddle around with from there.

Govtcheez
05-04-2006, 12:04 PM
Thanks Ken, but that brings up the same interface as the Manage Computer thing. I'll see if anything else is going on.

Ken Fitlike
05-04-2006, 12:10 PM
Are you sure about that? If you launch it from the 'run' command doesn't it throw up the 'services' window?

I might have an old hdd with win2k on it - give me a moment and i'll see if I can find it and fire it up....

edit: Okay, done that and I can confirm that you should definitely get the 'services' window if you start-->run--> services.msc.

Govtcheez
05-04-2006, 12:27 PM
Yeah, you do get the services window, but it looks very similar to the Manage Computer Interface, like services.msc just brings up that part of Manage Computer.

I'll try it next time that service randomly switches to Automatic from Disabled.

Ken Fitlike
05-04-2006, 12:44 PM
>>ike services.msc just brings up that part of Manage Computer.<<

Yes, it does. But that's what you need to fiddle around with to control how/what/where/when services run.

Good luck. :)

edit: Well, after actually reading the thread properly, it seems you already tried and died with services. Other things to look at: make sure there's no entry for the offending program in the startup menu and check the various registry 'run' keys to ensure it's not there either, for example(msconfig and its analogues essentially do this):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run]

If that still fails, you could always try a start-up script to disable it - the group policy editor might be useful in this regard (gpedit.msc).

hk_mp5kpdw
05-04-2006, 01:19 PM
I would think if you change it to disable then it will still startup when the computer reboots if was originally set to automatic, but maybe if you set it to manual, then it comes up as not started when you reboot (since you'd have to restart it manually each time). Maybe try that? :confused:

Fordy
05-04-2006, 03:33 PM
If you wanted a script, a simple bat file with "NET STOP" might suffice