PDA

View Full Version : problem: online on winxp and linux red hat



gemini_shooter
05-29-2005, 10:57 AM
Hello everybody !

Recently I have posted quite a few problems here, because I am trying to make a considerable effort to change to linux. I recently sucessfully installed red hat 9.0 and winxp dual boot but have run into quite a few problems...

This is a brief overview of what I did, created 10GB partition in bios and installed winxp(ntfs) on it, then from xp created a FAT32 (5GB) partition and another 5GB(NTFS) partition. Then I booted from red hat CD and installed red hat on remaining 8.6GB. It works fine... but here are the problems I face......


Problem 1 : I cannot see the FAT32 5GB partition from my linux OS, but I can see it feom winxp, can anyone help me on this ???

Problem 2: I have a LAN based internet connection which requires me to log on using a ISP client giving my username and password. The first time I looged on winxp I ran this client and was able to log on, I forgot to log out and restarted my computer and started linux and entered all the information in the network card like IP, DNS, gateway.

SURPRISINGLY It didn't even ask me to download the client and I was able to go online just by giving this information. PROBLEM: NOW I CANNOT GO ONLINE ON WinXP.....?????
I tried to do everything deactivate the card on linux and trying to log on in winxp. I am able to log on in XP but I cannot go online ......... internet expllorer just gives up it doesn't even try connect to the website......

Problem 3: I was trying to install the the internet client on linux as well, the instruction say to type this command ./install.sh from root mode, how to I log on to root mode, I have entered the root password and then tried this but the terminal tells me that I should be in root mode to run this

PLEASE HELP !!!!!!!

Perspective
05-29-2005, 12:02 PM
Ok, a few things

0. Redhat 9 is old and outdated. you should consider moving to Fedora. There has already been 3 fedora releases and fedora core 4 is due out in a month or so.

1. You need to mount the FAT partition. Find out what the name of your fat partition is. (you can do this by opening up a partition tool and listing the partitions). It will be something like hda1
If you want it to be mounted automatically (at /path/to/mount-point) you'll need to add a line to /etc/fstab ... something like this.


/dev/hda1 /path/to/mount-point vfat defaults 0 0

You can then list your mounted partitions/disk by typing: df -h

2. Thats a windows problem, no idea.

3. To swith to root you need to type su - then type your root password. Be sure to type exit when your done so you don't keep doing things as root.

gemini_shooter
05-29-2005, 12:22 PM
thanks for the response Perspective....

can you please tell in a much dumbber way how to mount the partition or how to automatically mount it ????

Perspective
05-29-2005, 01:22 PM
try the following commands (in bold) in a terminal:
su - # change to root
mkdir /mnt/myFatPartition # create a mount point (a place to access the partition)
nano /etc/fstab # nano is a text editor you can use any editor you want.
--- add the following line to your fstab file --


/dev/hda1 /mnt/myFatPartition vfat defaults 0 0

mount -a

Now the FAT partiton will be mounted everytime you start linux.

!!!! IMPORTANT: I'm just guessing at that your fat partition is hda1. If you created your ntfs partition first than the FAT partition could be hda2 or hda3. The only way to tell is to run a partition program to look at the partitions.

An example for doing this is to use a program called "parted"
su -
parted
(parted) print

You will see the fat32 partition and a number x. So, the device name will be hdax

gemini_shooter
05-29-2005, 01:33 PM
thanks I figured it out thanks for the tip , I really need help on the internet issue man ..........

This is my first time using linux and it would be a disastor if I cannot go online in winxp ..............

The mount gives me some relif that atleast I can transfer my files from windows if I want to attach them online, but I still need connection on Xp bad...............

Please help..................................

Perspective
05-29-2005, 02:14 PM
I don't see how connecting to the internet using linux could cause windows not to work. Maybe try reinstalling the client your ISP provided?

Your problem might get a little more attention if you post your internet troubles in the "Tech Board"