View Full Version : This is my first post...

10-20-2002, 07:51 AM
...from a linux machine.

Mandrake Linux 9 using Gnome that is. I managed to use my windows proxy to get the internet connection for this computer( I know that's a bit backwards ).

this is fascinating stuff actually. It's such a different environment though. It obviously mounted my windows drive and is able to access it from linux. That's pretty cool but I don't see how to access the network drives. Samba I assume is responsible for that.

disclaimer: this does not mean that I'm joining the legion of the undead who want to destroy microsoft at all costs.

10-20-2002, 08:20 AM
to mount the network drives:

mount //computer/drive /mnt/localdir -t smbfs

you might also need to specify a password and username

10-21-2002, 01:09 AM
Originally posted by FillYourBrain
...from a linux machine.

disclaimer: this does not mean that I'm joining the legion of the undead who want to destroy microsoft at all costs.

Maybe not, but at least you have seen that there are alternatives to Microsoft, and that isn't the easiest thing to know about because Microsoft is the first thing we ever know, and for most of us it is the only thing we ever know. When you say something bad about Microsoft, many believe that you are damning computers in general. They think that if you take away Microsoft, than there will be no such thing as computers.

Mandrake 9.0 instructions for installing Java2.
1) Bookmark (instructions page):
< http://java.sun.com/j2se/1.4.1/jre/install-linux.html >

2) Now go to < http://java.sun.com/j2se/1.4/download.html >
- See: Linux RPM in self extracting file.
- Open your shell and type (mkdir: Java2sdk)
- Download the SDK, not the JRE to this new directory.
- Return to bookmarked instruction page.
- Scroll down to 'Installation of RPM File' near the bottom of the page.
- In the shell, in the new directory type (ls) and make sure the download is there. It should say (j2sdk-1_4_0_02-linux-i586-rpm.bin).
- Type (chmod a+x j2sdk-1_4_0_02-linux-i586-rpm.bin).
- Type (./j2sdk-1_4_0_02-linux-i586-rpm.bin). Note the period.
- Type (ls) and notice that there are two files now, and they are not the same, one ends in .rpm, the other ends in .rpm.bin.
- Type (su) and enter your root password.
- Type (rpm -iv j2sdk-1_4_0_02-fcs-linux-i586.rpm).
- J2E is installed, but now you must add the plugin to your web browser so that you can display web pages in Java2.
- Remain as root and type (ln -s /usr/java/j2sdk1.4.0_02/jre/plugin/i386/ns610/libjavaplugin_oji.so /usr/lib/mozilla-1.1/plugins/).Creates a symbolic link. Note the space in there that doesn't show on this stupid message board.
- Exit as root and than exit as user.

It's all done. Pick up a book and write your java apps, except since the paths to (/usr/java/j2sdk1.4.0_02/jre/bin/) are not part of the $PATH, than you have to type the fully qualified name to compile your files and run them, for example (/usr/java/j2sdk1.4.0_02/jre/bin/javac myprog.java) compiles your java application, and (/usr/java/j2sdk1.4.0_02/jre/bin/java myprog) runs the java application. All the executables are in (/usr/java/j2sdk1.4.0_02/jre/bin/) get it? It would be easier to add that to your system PATH. This also holds true on Microsoft versions. Try writing a java appliation on Linux, than taking the exact same code (download J2E SDK on MS Windows just unzip the download and done) run that code on MS Windows. Now you know the power!

BTW to add Macromedia Flash to your Linux browsers go to (www.shockwave.com). A pile of popups will appear. Download the rpm as user. Unzip it with: (rpm -ivh filename.rpm). Than copy (cp) or cut and paste (mv) the ShockwaveFlash.class and the libjavaplugin_oji.so files to the mozilla plugin path (
/usr/lib/mozilla-1.1/plugins/). Now shockwave works on your browsers (the best browser is Galeon).

Note, to make life easier: when entering a filename or pathname, enter the first couple letters and press the tab key. That will expand the filename for you. It speeds things up.

10-21-2002, 03:06 PM
And download the documentation separate. Near the bottom of this page. Unzip it in your home directory, anywhere you want to keep it.
To view it type: (galeon index.html)

< http://java.sun.com/j2se/1.4.1/download.html#docs >

10-21-2002, 07:52 PM
ok, here's a problem. I am trying to make my network server a linux proxy server and connect it to the cable modem. I set up the nic on DHCP and it "seems" to get an external IP address as it should. but I attempt to ping or surf to a page and I get nothing. Any ideas?

10-21-2002, 08:51 PM
This is also my first post from Linux. Mandrake 9.0, amazing operating system. I've put programming aside for a few days to learn the basics (shell commands, etc)

Sorry FYB, i'm at the point where if something goes wrong, I have to format and reinstall. (2 times so far, oh well) so I have no clue about your question.

On another note, has anyone got UT2K3 demo working on linux?

10-21-2002, 10:57 PM
I'm not set up on a network, but I do have three computers using the same IP address, at the same time. They all have an ethernet card, and I have an ethernet hub that they all plug into, including the cable modem. I simply chose DHCP and my internet works on all systems. I did this during the setup.

There is a file /etc/hosts, where you can enter the IP and hostname of your provider. I manually entered it, but there was already a line entered into that file during setup. Type (cat /etc/hosts). See what you get. Enter you IP (emacs /etc/hosts)
IPAddress Hostname Computername

I don't know if that will fix your problem, like I said mine configured during setup, but I had a warning appear each time I used Gnome2.0 until I manually entered information into that file. If you have a static IP than I suppose that you can manually enter it instead of using DHCP, or even better, both enter it and use the DHCP option during setup.

Eribro, I reinstalled Linux about ten times, because each time I learned something new about the setup, such as being able to manually choose the individual packages that are installed.

Ctrl - x - s (save file in Emacs).
Ctrl - x - c (exit without saving in Emacs).

Shift - left mouse button (menu for font size)
Just make sure the cursor is inside the Emacs window for this last one.

10-21-2002, 11:14 PM
My Ethernet hub is a $10 piece of junk but it's lasted for years.

10-22-2002, 05:18 AM
ok, here's what I'm seeing with the two nics....

when the internal is deactivated, the external works. Meaning ping works and I have an internet connection. When internal and external are both activated, only internal pings work.

The only thing I can figure is that the internal network is somehow set up to be the default way of getting the internet connection or something. any ideas?

10-22-2002, 05:22 AM
Did you install the firewall? And if so what setting? High?

10-22-2002, 05:49 AM
I chose the firewall option in the installer but quite frankly haven't gotten around to configuring much of anything because of this 2 network card problem. I'll worry about firewall set up when I have access to both nics at the same time.

10-22-2002, 05:56 AM
I think that the firewall can have an affect on the internet connection. That's why I mentioned it, but it's difficult to say for sure. If you know that the firewall is off than it must be something else. I once messed with the firewall and couldn't get my browsers online.

Try asking at this forum < www.linuxquestions.org >

[second post]
I don't know anything about networks but I remember at the install that you have to make one computer a client, the other a server. There were client packages and server packages. So you have a domain server? You created a domain name for the client, so that the server can recognize it?

[third post]
Installing Linux as part of a domain would be more difficult than just doing a ordinary style install. It might require some actual reading. I have three computers (3 separate ethenet cards) and my cable modem all hooked up on one hub, and using the same IP (even though I used DHCP during install) and everything worked well on Mandrake 9.0 with no special configuration necessary, but if I had a domain server and I was integrating a Linux client, than that might be a different story. As far as I can tell, this is what you are saying. Oh well, sorry I can't find the answer, but it would be nice if you could hurry up and figure it out.

[fourth post]
Type: (ls /lib/modules/2.4.19-16mdk/kernel/drivers/net/ )

And see if your network card is listed.

4 posts put into one....

10-23-2002, 07:20 AM
I made tremendous progress last night! I can ping both internally and externally now! WOOHOO!!!!

a few steps upcoming:

1. CD rom isn't reading. that's strange, it's mounded and it worked during install obviously.

2. no sound. on board sound card. will I have to install the board's chipset drivers for linux?

3. socks proxy. what's it called in linux world. how do I get to it?