PDA

View Full Version : Floppy/Zip problems



JasonLikesJava
06-10-2002, 11:26 AM
I know this is a programming board but I've looked all over and asked all over and I couldn't find an answer to this problem. I thought I'd try the experts over here....

I have Mandrake 8.2 installed and I am having the same problems with both my Zip drive and my floppy drive. They are both mounted fine and all but when I remove any files from either of them, the disk space the files took is not freed. So if I fill up a 100mb zip disk and then delete everything on it, it still says it contains 100/100mb of free space. I've searched everywhere for how do fix this but I haven't found anyone else with this problem.

Thanks.

linuxgeek
06-10-2002, 02:06 PM
Linux doesn't commit it's filesystem changes right away. This is very obvious when using removable media. You could try issuing the command "update" from a shell to force a filesystem flush. You can also unmount/remount the drive to force the flush.

starX
06-10-2002, 08:22 PM
you should ALWAYS unmount the drive before removing the media from the drive. This will force synchronization between the filesystem records, and what is actually contained on the disk. This goes for writeable media (like floppies) as well as for read only media (like a cdrom).

Consequently, this is the same reason why you should use the shutdown command instead of turning the power off, as shutdown will unmount all of the mounted drives, including your hard drive, and make sure that everything is synced up.

Just in case you don't know how, to unmount a floppy, issue the command:

umount /mnt/floppy

or whatever else your floppy mount point may be. The same goes for your zip drive. I think you can do this is GNOME by right-clicking on the floppy icon, but I'm not sure about that.

starX
www.axisoftime.com

JasonLikesJava
06-11-2002, 11:27 AM
Hmm.... I tried that and it didn't work. I did both 'update' and unmounted it and I've still got the same problem. I haven't tried it with a floppy yet, but I assume it would be the same.

JasonLikesJava
06-12-2002, 12:12 PM
I'll try it with a floppy and see what happens.