PDA

View Full Version : Bad Interpreter



JasonLikesJava
05-22-2002, 10:30 AM
What does this mean and how can I fix it?

bash:./configure:bad interpreter:file or directory not found

JasonLikesJava
05-22-2002, 11:18 AM
The top has #!/bin/sh like any other configure script...

mix0matt
05-22-2002, 09:59 PM
change the permissions...make sure that you can execute the script...

JasonLikesJava
05-23-2002, 10:32 AM
Doh :eek:

I should have thought of that....

JasonLikesJava
05-24-2002, 11:00 AM
OK.... so I thought I hadn't made it executable, but it was all along. Here's some more information... maybe something will help. I downloaded winex from CVS using windows ::gag:: I had never used CVS before but I seem to have eventually gotten it all down. So then I fled from windows and booted up to linux and copied the wine directory from my windows partition to linux. From there I entered the directory and tried to configure it and it wouldn't work. Just for the heck of it I renamed the configure file to something like "justatest" and then executed it and instead of

bash:./configure:bad interpreter:file or directory not found

I got

bash:./configure:bad interpreter:Permission denied

I'm really confused...:confused:

Lynux-Penguin
05-25-2002, 12:07 AM
perhaps its actually
/bin/sh
change
#!/bin/sh
to
#!/bin/bash
if you have the BASH shell that is, if it still has the interpreter problem, try looking at the script and look for spelling error or maybe even an outdated command
sometimes sbin commands are outdated on older scripts.

JasonLikesJava
05-28-2002, 10:24 AM
I wouldn't think I would have to change anything since it was downloaded just a few days ago off of winex. I'll try what you said though.

JasonLikesJava
05-29-2002, 10:14 AM
Fixed it :D

All of the line ends were wrong... they were all CR+LF instead of LF. I had suspected this although I wasn't exactly sure how to check and then change them... but I figured it out.

muttski
05-30-2002, 03:29 PM
Your both sephiroth, or is JasonLikeJava's avatar not sephiroth?

JasonLikesJava
05-31-2002, 11:16 AM
Yeah, I'm sephiroth.... but I'm not really into Final Fantasy. I didn't even know mine and Lynux-Penguin's were the same...