PDA

View Full Version : Need Help with new gcc



kwigibo
03-28-2002, 07:54 PM
Hi all

Im having trouble getting the new version of gcc-3.0.4 to install properly.

I follow the steps as follow

1. Download source
2. type from destination directory
sh ../srcdir/configure
3. make bootstrap
4. make -k check
5. make install

then i type at the prompt
$ gcc -v

and it tells me it is the old one
gcc 2.96-81


Help would be appreciated. I think i know where the problem is but not sure how to fix it. I think i need to add options to the second step. These options can be found at the http://gcc.gnu.org.

SYSTEM DETAILS

redhat 7.1
kernel ------ 2.4.2-2
gcc --------- 2.96-81
glibc-devel - 2.2.2-10
make -------- 3.79.1-5
binutils ---- 2.10.91.0.2-3

Any other info needed email me directly at
q1121516@mail.connect.usq.edu.au

starX
03-29-2002, 12:55 AM
While I'm not entirely certain, I'm willing to bet that the new version just isn't in your PATH properly. It sounds like you have a symlink to your older version, or your older version is actually installed in /usr/bin.

Try making your /usr/bin/gcc file a symlink to the new version of the gcc executeable. If I'm right, that'll clear it up.

starX
www.axisoftime.com

kwigibo
03-29-2002, 11:38 PM
Yes that is practically what it was. After posting this message I tried again and voila it worked because I added an option to the end. But the problem is now that I installed it because at uni we need a compiler to comply with the new c++ standard. I compiled my source code on the old one worked alright (least it compiled) now it won't compile. I think this is something I'll I have to work through though. Thanks for you help anywayz.