PDA

View Full Version : solaris 10 keyboard problems



Tool
02-26-2010, 07:48 AM
Hi, i installed Solaris 10 today.

After successfully setting the keyboard layout to Croatian, i also wanted to change some keys like [ etc because they werent set properly, weirdly (even though i chose the correct keyboard layout).

So i got advised to execute this code in the terminal loged in as root:


mkdir -p /etc/dt/config
cp /usr/dt/config/Xstartup /etc/dt/config/
cat >> /etc/dt/config/Xstartup <<%EOF%
xmodmap -e "keycode 55 = v V at grave"
xmodmap -e "keycode 24 = q Q backslash Greek_OMEGA"
xmodmap -e "keycode 25 = w W bar Lstroke"
xmodmap -e "keycode 26 = e E EuroSign EuroSign"
xmodmap -e "keycode 41 = f F bracketleft ordfeminine"
xmodmap -e "keycode 42 = g G bracketright ENG"
xmodmap -e "keycode 45 = k K lstroke ampersand"
xmodmap -e "keycode 46 = l L lstroke Lstroke"
xmodmap -e "keycode 56 = b B braceleft apostrophe"
xmodmap -e "keycode 57 = n N braceright braceright"
xmodmap -e "keycode 58 = m M asciicircum masculine"
%EOF%

Which i did.

After this, i loged out, and after that every time i get to the login screen, i enter root - after that solaris goes to console for a sec, and then again back to login screen. And so on. I cant get in the GUI, i just enter root at login, it goes back to console for a second and then back to login.

What did i do?

MK27
02-26-2010, 08:07 AM
Well, obviously this file did not exist before BUT it is part of some potential default search path for "Xstartup", otherwise it could not do anything at all.

If the pattern is that we check for this file until we find ONE, then you may have overridden a different, existing Xstartup in some other location. Possibly, if you intend to use multiple Xstartups, you are suppose to source one from the other.

Just a guess...anyway, mount the partition from somewhere else (eg, a cdrom) and remove that file you added.

Tool
02-26-2010, 08:36 AM
I entered console mode.

I tried deleting
/etc/dt/config

It didnt work. :(

Tool
02-26-2010, 08:36 AM
Is there a command to boot solaris from the console?

MK27
02-26-2010, 08:43 AM
You installed "today", you said. Are you positive this is the problem?

I'd stop wasting time and reinstall (how long does it take, 1/2 hour?). You are smart to do little experiments like this right away, when it is easy and harmless to reinstall repeatedly (nothing wrong with that), until you gain a better understanding, which will come at least in part from hands-on experimentation. Like for example: installing/reinstalling.

Tool
02-26-2010, 09:39 AM
This is my 4th installation.

It happened all 4 times no matter what i tried.

I just need to change the 3 lines before xmodmap. It seems to me like im doing something bad with them.

MK27
02-26-2010, 10:35 AM
mkdir -p /etc/dt/config
cp /usr/dt/config/Xstartup /etc/dt/config/
cat >> /etc/dt/config/Xstartup <<%EOF%


Well, they won't do anything serious in and of themselves. However, cat>> is append, so here's a few thoughts.

1) what is dt? (as in, /usr/config/dt, /etc/dt) It could be that by placing that file in the /etc directory, you are activating "it" -- ie, with the file just in /usr, "dt" does not run. Or runs differently.
2) What else is in Xstartup?
3) if the file in /usr is used AND the one in etc is also used, whatever you appended to is executed twice.