Thread: So I wrote a class.

  1. #1
    Officially An Architect brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,396

    So I wrote a class.

    I wrote a class. Its name was: CXDGJUIMXDC. Can anyone suggest a better name? K thnx bye.
    Code:
    //try
    //{
    	if (a) do { f( b); } while(1);
    	else   do { f(!b); } while(1);
    //}

  2. #2
    & the hat of GPL slaying Thantos's Avatar
    Join Date
    Sep 2001
    Posts
    5,681
    O00O00O00000OO00OOOO00000O is a better name

  3. #3
    Woof, woof! zacs7's Avatar
    Join Date
    Mar 2007
    Location
    Australia
    Posts
    3,459
    l1l1l1l1l1l1l1l1l1l1l100O0O0O0O0OO0O0O0Ol1l1l1l1l1 l1l1l1l1l1l1l (lol)

  4. #4
    and the hat of copycat stevesmithx's Avatar
    Join Date
    Sep 2007
    Posts
    587
    Gav3eosestel4allghkaz9avnubreg5gex9resylu4gaplao7v apwebkoa8owloe
    Edit:
    There seems to be bug:
    Between v and a i didn't include any space in my post.
    Apparently zacs7 should have had the same problem, methinks.
    On second thought it could be a feature.
    who on earth is going to use a word that is 50 characters long?
    Last edited by stevesmithx; 12-12-2008 at 11:19 PM. Reason: forum bug?
    Not everything that can be counted counts, and not everything that counts can be counted
    - Albert Einstein.


    No programming language is perfect. There is not even a single best language; there are only languages well suited or perhaps poorly suited for particular purposes.
    - Herbert Mayer

  5. #5
    Officially An Architect brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,396
    You only THINK it means nothing.

    Class XPS Driver Golden Jet User Interface Microsoft XPS Document Converter.

    Makes sense? Okay.
    Code:
    //try
    //{
    	if (a) do { f( b); } while(1);
    	else   do { f(!b); } while(1);
    //}

  6. #6
    and the hat of copycat stevesmithx's Avatar
    Join Date
    Sep 2007
    Posts
    587
    Ah!That's a really long acronym.
    I guess your sig holds true here.
    Last edited by stevesmithx; 12-13-2008 at 12:16 AM.
    Not everything that can be counted counts, and not everything that counts can be counted
    - Albert Einstein.


    No programming language is perfect. There is not even a single best language; there are only languages well suited or perhaps poorly suited for particular purposes.
    - Herbert Mayer

  7. #7
    Woof, woof! zacs7's Avatar
    Join Date
    Mar 2007
    Location
    Australia
    Posts
    3,459
    At least it's descriptive...

  8. #8
    Malum in se abachler's Avatar
    Join Date
    Apr 2007
    Posts
    3,195
    Quote Originally Posted by brewbuck View Post
    I wrote a class. Its name was: CXDGJUIMXDC. Can anyone suggest a better name? K thnx bye.
    Code:
    class MyClass {
       };

  9. #9
    Registered User
    Join Date
    Sep 2008
    Location
    St. Petersburg, FL
    Posts
    35
    class void_main

    best joke name i could think of at this hour.

  10. #10
    chococoder
    Join Date
    Nov 2004
    Posts
    515
    Quote Originally Posted by brewbuck View Post
    You only THINK it means nothing.

    Class XPS Driver Golden Jet User Interface Microsoft XPS Document Converter.

    Makes sense? Okay.
    XpsDriverGoldenJetUIMSXpsDocCon makes sense and isn't impossibly long (meaning, I've seen and created longer names).

  11. #11
    Cat without Hat CornedBee's Avatar
    Join Date
    Apr 2003
    Posts
    8,895
    Why not just XPSConverter? What other kinds of XPSs are there?
    All the buzzt!
    CornedBee

    "There is not now, nor has there ever been, nor will there ever be, any programming language in which it is the least bit difficult to write bad code."
    - Flon's Law

  12. #12
    The superhaterodyne twomers's Avatar
    Join Date
    Dec 2005
    Location
    Ireland
    Posts
    2,273
    Why not Class_XPS_Driver_Golden_Jet_User_Interface_Microso ft_XPS_Document_Converter?

    Edit: Weird. I've got a space in Microsoft.....

  13. #13
    The larch
    Join Date
    May 2006
    Posts
    3,573
    XDGJUIMXDC - the C prefix is pretty much meaningless and confused a lot of people here
    I might be wrong.

    Thank you, anon. You sure know how to recognize different types of trees from quite a long way away.
    Quoted more than 1000 times (I hope).

  14. #14
    Ethernal Noob
    Join Date
    Nov 2001
    Posts
    1,901
    Class XPS Driver Golden Jet User Interface Microsoft XPS Document Converter.

    Why not just put it in the namespace GoldenJet::UI::XPS:: DocumentConverter

  15. #15
    Officially An Architect brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,396
    Quote Originally Posted by indigo0086 View Post
    Class XPS Driver Golden Jet User Interface Microsoft XPS Document Converter.

    Why not just put it in the namespace GoldenJet::UI::XPS:: DocumentConverter
    Because it's not a document converter, it's not part of the UI, and it has nothing to do with Microsoft. That's just what UIMXDC happens to stand for.

    In fact, this class only exist in order to implement one of the methods defined in the IPrintOemUIMXDC interface. Since the basic piece of software here is an XPS driver called "Golden Jet" the name goes: XPS Driver, Golden Jet, the part which implements that stupid UIMXDC thing.

    IPrintOemUIMXDC is an interface exported by a Unidrv UI plugin which provides three methods that MXDC uses to determine how to perform certain actions when converting a GDI print job to an XPS document. In this case I need to control the image compression (i.e. disable it).

    So the name didn't arise as capriciously as it might seem at first. It still sucks though.
    Code:
    //try
    //{
    	if (a) do { f( b); } while(1);
    	else   do { f(!b); } while(1);
    //}

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Specializing class
    By Elysia in forum C++ Programming
    Replies: 6
    Last Post: 09-28-2008, 04:30 AM
  2. Screwy Linker Error - VC2005
    By Tonto in forum C++ Programming
    Replies: 5
    Last Post: 06-19-2007, 02:39 PM
  3. Creating a database
    By Shamino in forum Game Programming
    Replies: 19
    Last Post: 06-10-2007, 01:09 PM
  4. Replies: 7
    Last Post: 05-26-2005, 10:48 AM