RegSetValueEx

This is a discussion on RegSetValueEx within the Windows Programming forums, part of the Platform Specific Boards category; Hello everyone, I find that when using Debug build, we do not need to set linker --> input --> Advapi32.lib, ...

  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    1,579

    RegSetValueEx

    Hello everyone,


    I find that when using Debug build, we do not need to set linker --> input --> Advapi32.lib, but when using Release build, we need to set linker --> input --> Advapi32.lib. Or else, there will be error message, unresolved symbol RegSetValueEx.

    I am using Visual Studio 2005.


    thanks in advance,
    George

  2. #2
    Registered User
    Join Date
    Oct 2001
    Posts
    2,129
    question?

  3. #3
    Deathray Engineer MacGyver's Avatar
    Join Date
    Mar 2007
    Posts
    3,211
    Maybe whatever IDE you're using automatically links with it when compiling in debug mode.

  4. #4
    Registered User
    Join Date
    Aug 2007
    Posts
    13
    If you're asking why, I guess its because they wanted to automatically put libraries in Debug mode, for ease of use. But for Release mode, doing that would bloat the program too much.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. RegSetValueEx and REG_MULTI_SZ
    By Tuborgrules in forum Windows Programming
    Replies: 6
    Last Post: 09-29-2009, 03:50 AM
  2. Registry manipulation
    By tezcatlipooca in forum Windows Programming
    Replies: 3
    Last Post: 04-29-2007, 05:45 PM
  3. RegSetValueEx
    By RhondaNichols in forum C++ Programming
    Replies: 4
    Last Post: 03-30-2005, 08:26 AM
  4. RegSetValueEx doesn't do anything
    By Xzyx987X in forum Windows Programming
    Replies: 2
    Last Post: 09-15-2003, 12:28 PM
  5. RegSetValueEx() problem
    By Kupo in forum Windows Programming
    Replies: 1
    Last Post: 02-09-2002, 10:16 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21