GetAsyncKeyState( ); Not Working!

This is a discussion on GetAsyncKeyState( ); Not Working! within the Windows Programming forums, part of the Platform Specific Boards category; Works : if(GetAsyncKeyState(VK_F1)) Works : if(GetAsyncKeyState(VK_LEFT)) Does not work : if(GetAsyncKeyState((50))) It just don't get it. It works with a ...

  1. #1
    Registered User Queatrix's Avatar
    Join Date
    Apr 2005
    Posts
    1,342

    GetAsyncKeyState( ); Not Working!

    Works: if(GetAsyncKeyState(VK_F1))
    Works: if(GetAsyncKeyState(VK_LEFT))
    Does not work: if(GetAsyncKeyState((50)))

    It just don't get it. It works with a VK command, but when I try to get it to work with one of the letter keys, nothing happens, I don't get an error, it's just that it doen't work.

    Please help! Thanks, August.

  2. #2
    Skunkmeister Stoned_Coder's Avatar
    Join Date
    Aug 2001
    Posts
    2,572
    0x50??
    remove superfluous parenthesis
    Free the weed!! Class B to class C is not good enough!!
    And the FAQ is here :- http://faq.cprogramming.com/cgi-bin/smartfaq.cgi

  3. #3
    Registered User Queatrix's Avatar
    Join Date
    Apr 2005
    Posts
    1,342
    This doesn't work any more than before:

    if(GetAsyncKeyState(50))

  4. #4
    Skunkmeister Stoned_Coder's Avatar
    Join Date
    Aug 2001
    Posts
    2,572
    try pressing '2' for 50. As i said 0x50 is maybe what you want.
    Free the weed!! Class B to class C is not good enough!!
    And the FAQ is here :- http://faq.cprogramming.com/cgi-bin/smartfaq.cgi

  5. #5
    Registered User Queatrix's Avatar
    Join Date
    Apr 2005
    Posts
    1,342
    Thanks, I got it working now!

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Function not working
    By sloopy in forum C Programming
    Replies: 31
    Last Post: 11-12-2005, 07:08 PM
  2. Program Not working Right
    By raven420smoke in forum C++ Programming
    Replies: 2
    Last Post: 09-16-2005, 03:21 AM
  3. Trying to eject D drive using code, but not working... :(
    By snowfrog in forum C++ Programming
    Replies: 3
    Last Post: 05-07-2005, 07:47 PM
  4. x on upper right corner not working
    By caduardo21 in forum Windows Programming
    Replies: 1
    Last Post: 02-20-2005, 07:35 PM
  5. cygwin -> unix , my code not working properly ;(
    By CyC|OpS in forum C Programming
    Replies: 4
    Last Post: 05-18-2002, 04:08 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21