Question about dialogs... weird problem

This is a discussion on Question about dialogs... weird problem within the Windows Programming forums, part of the Platform Specific Boards category; Hello everybody! I already asked this question in C++, and over there they told me to ask here. I asked ...

  1. #1
    Registered User
    Join Date
    Feb 2005
    Posts
    8

    Question Question about dialogs... weird problem

    Hello everybody!

    I already asked this question in C++, and over there they told me to ask here. I asked it here, but my thread got locked...

    anyway, I didn't really get an answer, and I asked around but I really couldn't find an answer to my problem!
    (this time I'm adding a pic, so maybe someone will be able to understand my poor description of the problem and help me with this).

    in the resource view, I created a dialog, and I called this dialog using DoModal (obviously, m_dNum1 is the variable of the dialog):
    m_dNum1.DoModal();

    so instead of seeing it normally (as seen in the resource view), I'm seeing it with the defualt dialog text and buttons (as seen in the picture added...).

    I'm really REALLY LOST!
    so ANYONE???

    THANKS ALOT!!!!
    Attached Images Attached Images  

  2. #2
    Registered User
    Join Date
    Sep 2004
    Location
    California
    Posts
    3,246
    Post the contents of your resource file.

  3. #3
    train spotter
    Join Date
    Aug 2001
    Location
    near a computer
    Posts
    3,855
    Are you using the window setting 'Large fonts'?

    This changes the size of text (and so position) on a dlg but not the size of the controls.
    "Man alone suffers so excruciatingly in the world that he was compelled to invent laughter."
    Friedrich Nietzsche

    "I spent a lot of my money on booze, birds and fast cars......the rest I squandered."
    George Best

    "If you are going through hell....keep going."
    Winston Churchill

  4. #4
    Registered User
    Join Date
    Feb 2005
    Posts
    8
    I am not using 'Large Fonts', just the default settings of windows...

    and about the content of the resource file, do you mean the content of 'resource.h'?
    (sorry for the dumb questions, I'm pretty much walking in the dark around here, I'm using a book to study all this, but it says nothing about this kind of error...)

  5. #5
    Registered User
    Join Date
    Sep 2004
    Location
    California
    Posts
    3,246
    do you mean the content of 'resource.h'?
    No, I mean the contents of your .rc file.

  6. #6
    Registered User
    Join Date
    Feb 2005
    Posts
    8
    yeah, I got it! :-)
    thanks! :-)
    I just sat on that for like half an hour, just trying to see whats going on over there, and I kinda solved it.
    for some WEIRD REASON, the visual created an HTML file that in there I can see the dialog the was shown on the back.
    all I did to fix that was to delete the line that calls that function from the OnInit,
    and it got okay, but I still couldn't do it to delete the lines that controls the HTML buttons, I'm getting errors when I'm deleting them, and no matter what I'm trying to do I can't completly delete any trace of this weird HTML phenomena, or understand whats causing it.

    have you heard of anything like that and explain to me what kind of demon possess my computer? :-)

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Weird problem with textures
    By KgNe in forum Game Programming
    Replies: 8
    Last Post: 01-15-2009, 04:24 PM
  2. Weird printf() problem
    By stanlvw in forum C++ Programming
    Replies: 2
    Last Post: 02-23-2008, 01:29 AM
  3. Replies: 12
    Last Post: 02-20-2005, 07:48 AM
  4. Weird mouse problem in XP
    By VirtualAce in forum Game Programming
    Replies: 5
    Last Post: 06-16-2004, 11:47 AM
  5. Weird problem
    By khpuce in forum Tech Board
    Replies: 0
    Last Post: 04-29-2004, 08:29 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21