Can't load string from resource DLL's string table

This is a discussion on Can't load string from resource DLL's string table within the Windows Programming forums, part of the Platform Specific Boards category; Hi, I use resource DLLs to provide multilingual environment to users - user select language, I call AfxSetResourceHandle() with handle ...

  1. #1
    s_k
    s_k is offline
    Registered User
    Join Date
    Feb 2003
    Posts
    4

    Can't load string from resource DLL's string table

    Hi, I use resource DLLs to provide multilingual environment to users - user select language, I call AfxSetResourceHandle() with handle of relevant DLL and in all functions that load some kind of resource, I use AfxGetResourceHandle().

    It works great (I have six resource DLLs now + base project, which is in english).

    Of course I use same resource symbols in resource.h, with the same values.

    But sometimes happens that I'm not able to load certain string from string table of one of DLLs. It has the same value assigned in resource.h as in all others DLLs but it just doesn't work. The only thing that helps that I must add new string to all DLLs and change the code to use this symbol instead of the old one.

    I really don't understand what the problem is

    What could be the reason?

    Have you ever met some similar problem?

  2. #2
    Registered User Codeplug's Avatar
    Join Date
    Mar 2003
    Posts
    4,662
    Hmmmm, I would double and tripple check each DLL project and make certain that the correct ID is associated with each string.
    I've run into similiar situations and the fault was either mine or I just needed to clean and re-build the project (Visual Studio is goofey sometimes).

    gg

  3. #3
    s_k
    s_k is offline
    Registered User
    Join Date
    Feb 2003
    Posts
    4
    It's sure that the strings have the same symbols/values in each project. But just one DLL of six is unable to load that string . The DLL and main project have the identical resource.h files (not physically but the content is identicall).

  4. #4
    Registered User Codeplug's Avatar
    Join Date
    Mar 2003
    Posts
    4,662
    Are the project settings the same as well (same compiler/linker flags etc...)?
    Are you sure that entire project is getting rebuilt when needed?
    Could it be a bug in your code somehow for this one DLL?

    Can't think of anything else...

    gg

  5. #5
    s_k
    s_k is offline
    Registered User
    Join Date
    Feb 2003
    Posts
    4
    Compiler settings is the same for all of DLLs. The code makes absolutely no difference between DLLs, it's transparent for the language used. Now I rebuilt all but didn't help...

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. OOP Question DB Access Wrapper Classes
    By digioz in forum C# Programming
    Replies: 2
    Last Post: 09-07-2008, 04:30 PM
  2. Inheritance Hierarchy for a Package class
    By twickre in forum C++ Programming
    Replies: 7
    Last Post: 12-08-2007, 03:13 PM
  3. Custom String class gives problem with another prog.
    By I BLcK I in forum C++ Programming
    Replies: 1
    Last Post: 12-18-2006, 02:40 AM
  4. string handling
    By lessrain in forum C Programming
    Replies: 3
    Last Post: 04-24-2002, 07:36 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21