weird errors...

This is a discussion on weird errors... within the Windows Programming forums, part of the Platform Specific Boards category; hello, just wondering if anyone has experienced the same thing that is happening to me and if anyone knows if ...

  1. #1
    dug
    dug is offline
    Registered User dug's Avatar
    Join Date
    Jun 2003
    Posts
    66

    weird errors...

    hello,

    just wondering if anyone has experienced the same thing that is happening to me and if anyone knows if there's a simple remedy?

    basically i'm coding a small MFC application, and everytime i run the app in 'debug' mode... when the program starts up i get an error message box that says 'There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\DR1.'.... so i hit cancel and it reappears about 4 times... so i press 'cancel' each time... and then the program runs fine.... so i don't really think much about it....

    so i build a release version of the app and i run it.... no problems at first, and then i open up a child window and 'BLAM!' i get an application error... it says 'The exception Priveleged instruction. (0xc0000096) occurred in the application at location 0x0012fc88. click ok to terminate etc. etc.'

    so i dug around on google and priveleged instruction seems to be linked with accessing ports, or devices... so i figured the two were related... so i run the release again and choose debug.... step through for ages and then eventually i trigger another message that appears and says 'there is no disk in the drive. please insert a disk into drive \Device\Harddisk1\DR1.' same as the one i get in the debug build... so i'm 99% convinced that they are linked...

    so has anyone had the same problem or recognise this? i can't think what could possiblly be causing this so any ideas would be really appreciated!!

    cheers guys,
    dug.

  2. #2
    Carnivore ('-'v) Hunter2's Avatar
    Join Date
    May 2002
    Posts
    2,879
    Don't know what the problem is, but there are a few standard solutions that seem to work for most unexpected problems:

    a) Go "rebuild all"
    b) Find out what's wrong
    c) Delete your code and do it all over again
    d) Kill MFC and use normal Windows API. I'm a MFC hater
    e) Reinstall your compiler
    f) Reinstall windows
    g) Reinstall windows, reinstall your compiler, kill MFC and redo your code
    h) Format your harddrive and reinstall Windows
    i) Buy a new harddrive
    j) Buy a new motherboard
    k) Buy a new computer
    l) All of the above
    m) Options (a) and (b), and possibly (c) (least recommended)
    Last edited by Hunter2; 06-26-2003 at 06:13 PM.
    Just Google It. √

    (\ /)
    ( . .)
    c(")(") This is bunny. Copy and paste bunny into your signature to help him gain world domination.

  3. #3
    dug
    dug is offline
    Registered User dug's Avatar
    Join Date
    Jun 2003
    Posts
    66
    hehe... not the most useful reply i've ever had... but pretty funny nonetheless. unfortunately... none of the [sensible] suggestions seem to work... and i put a breakpoint at the very very start of the 'initinstance' call for the application... and guess what? the problem still happens... anyone else got some tips?

  4. #4
    dug
    dug is offline
    Registered User dug's Avatar
    Join Date
    Jun 2003
    Posts
    66
    AHA! AHAHAHHAHAHHAHA!!!!

    libtiff.lib

  5. #5
    dug
    dug is offline
    Registered User dug's Avatar
    Join Date
    Jun 2003
    Posts
    66
    nope, nevermind.... its weird.. if irun the debug version through MSDEV i get the error.... if i just run the debug version directly... no error... but the release version still crashes.... i dunno.

  6. #6
    Carnivore ('-'v) Hunter2's Avatar
    Join Date
    May 2002
    Posts
    2,879
    Sorry, no clue. Are you accessing files? And could you post some code?
    Just Google It. √

    (\ /)
    ( . .)
    c(")(") This is bunny. Copy and paste bunny into your signature to help him gain world domination.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. HELP with DX9 Errors!!!
    By Tommaso in forum Game Programming
    Replies: 7
    Last Post: 06-28-2006, 03:51 PM
  2. Errors with header files in OpenGL using VisualC++
    By wile_spice in forum Game Programming
    Replies: 3
    Last Post: 06-22-2006, 09:56 AM
  3. Weird Errors in VS 2003
    By Devil Panther in forum Windows Programming
    Replies: 1
    Last Post: 10-01-2005, 07:16 AM
  4. executing errors
    By s0ul2squeeze in forum C++ Programming
    Replies: 3
    Last Post: 03-26-2002, 01:43 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21