WM_CREATE not working??

This is a discussion on WM_CREATE not working?? within the Windows Programming forums, part of the Platform Specific Boards category; Any Ideas as to why any code I put into WM_CREATE isn's executed?? here's part of my program: Code: BOOL ...

  1. #1
    Unregistered
    Guest

    WM_CREATE not working??

    Any Ideas as to why any code I put into WM_CREATE isn's executed??
    here's part of my program:
    Code:
    BOOL CALLBACK ConfigDialogProc(HWND hwnd, UINT Message, WPARAM wParam, LPARAM lParam)
    {
    	switch (Message)										
        {
    	case WM_CREATE:
    		SetDlgItemText(hwnd, IDC_WENEW, WEmailDriveNames);
    		break;
    	case WM_COMMAND:
    		{
    			switch(LOWORD(wParam))
    			{
    			case IDSAVE:
    				Save_Settings();
    				EndDialog(hwnd, IDSAVE);
    				return TRUE;
    				break;
    			case IDCANCEL:
    				EndDialog(hwnd, IDCANCEL);
    				return TRUE;
    				break;
    			}
    		}
    		break;
    	}
    	
    	return DefWindowProc (hwnd, Message, wParam, lParam);
    }

  2. #2
    Registered User
    Join Date
    Mar 2002
    Posts
    18
    Use WM_INITDIALOG for a dialog box.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Function not working
    By sloopy in forum C Programming
    Replies: 31
    Last Post: 11-12-2005, 08:08 PM
  2. Program Not working Right
    By raven420smoke in forum C++ Programming
    Replies: 2
    Last Post: 09-16-2005, 04:21 AM
  3. Trying to eject D drive using code, but not working... :(
    By snowfrog in forum C++ Programming
    Replies: 3
    Last Post: 05-07-2005, 08:47 PM
  4. x on upper right corner not working
    By caduardo21 in forum Windows Programming
    Replies: 1
    Last Post: 02-20-2005, 08:35 PM
  5. cygwin -> unix , my code not working properly ;(
    By CyC|OpS in forum C Programming
    Replies: 4
    Last Post: 05-18-2002, 05:08 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21