building the project issue

This is a discussion on building the project issue within the Windows Programming forums, part of the Platform Specific Boards category; hi all I have a problem with building the project in Microsoft Visual Studio when i build the project it ...

  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    9

    building the project issue

    hi all

    I have a problem with building the project in Microsoft Visual Studio

    when i build the project it works fine in my computer but when i tried to start it in another PC this massage box appear

    Name:  untitled.JPG
Views: 71
Size:  14.8 KB

    Plz help

    PS : My Project is CLR Form Windows with target framework 2.0
    Last edited by Salem; 12-31-2010 at 08:51 AM. Reason: Removed pointless centre tags

  2. #2
    and the hat of wrongness Salem's Avatar
    Join Date
    Aug 2001
    Location
    The edge of the known universe
    Posts
    32,344
    You will have more success (probably) if you copy the Release version (not the Debug version) to other machines.
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper.
    I support http://www.ukip.org/ as the first necessary step to a free Europe.

  3. #3
    Registered User
    Join Date
    Dec 2010
    Posts
    9
    can you tell me the steps to create a Release version ??

  4. #4
    and the Hat of Guessing tabstop's Avatar
    Join Date
    Nov 2007
    Posts
    14,185
    You should have a drop-down box in your Visual Studio that has Debug and Release as options. Mine's toward the middle of the screen, right next to the "play" button that starts debugging.

  5. #5
    Registered User
    Join Date
    Dec 2010
    Posts
    9
    thanks but that doesn't solve my problem
    the same massage ...

  6. #6
    and the Hat of Guessing tabstop's Avatar
    Join Date
    Nov 2007
    Posts
    14,185
    Does the machine you are trying to run it on have the C runtime installed? (If VC is not installed on that machine, the answer is almost certainly "no".) If it doesn't you'll have to get it on there.

    See, for example, here.

  7. #7
    Registered User
    Join Date
    Dec 2010
    Posts
    9
    its installed in the other PC !!

  8. #8
    train spotter
    Join Date
    Aug 2001
    Location
    near a computer
    Posts
    3,856
    Do you have other files (libs, DLLs) statically linked in the root folder .\CTRScetcher?

    If so, remove the 'debug' folder and add the .exe to the main 'CTRScetcher' folder.

    What version of MSVC are you using?
    "Man alone suffers so excruciatingly in the world that he was compelled to invent laughter."
    Friedrich Nietzsche

    "I spent a lot of my money on booze, birds and fast cars......the rest I squandered."
    George Best

    "If you are going through hell....keep going."
    Winston Churchill

  9. #9
    Registered User
    Join Date
    Dec 2010
    Posts
    9
    no i haven't libs or DLLs in the root folder of the project
    I used the framework 3.5 with the libs of System :: Drawing .
    Iam using 2008 v.
    no progress done

  10. #10
    Registered User
    Join Date
    Dec 2010
    Posts
    9
    problem solved !!!!
    thanks every one ..

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Paid project - The Free Marketing Project
    By sharefree in forum Projects and Job Recruitment
    Replies: 0
    Last Post: 10-27-2010, 02:15 PM
  2. Building a project using a Makefile
    By starcatcher in forum Windows Programming
    Replies: 2
    Last Post: 11-23-2008, 10:50 PM
  3. Project details: Dedicated
    By Stack Overflow in forum Projects and Job Recruitment
    Replies: 9
    Last Post: 02-22-2005, 02:10 PM
  4. I'm building a gun at school...
    By Jeremy G in forum A Brief History of Cprogramming.com
    Replies: 11
    Last Post: 09-24-2004, 11:41 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21