NIS client configuration on Fedora 5

This is a discussion on NIS client configuration on Fedora 5 within the Tech Board forums, part of the Community Boards category; I'm having a problem with NIS (client) configuration on a FC5 machine. What I'm seeing is, ypbind is in the ...

  1. #1
    Registered User
    Join Date
    Aug 2002
    Location
    Hermosa Beach, CA
    Posts
    446

    NIS client configuration on Fedora 5

    I'm having a problem with NIS (client) configuration on a FC5 machine. What I'm seeing is, ypbind is in the startup sequence for xinetd. The /etc/yp.conf file is present and configured correctly, i.e.

    domain MYDOMAIN server MACHINE_NAME

    And I read somewhere that I'm supposed to have the line:

    NIS_DOMAIN=MYDOMAIN

    in the file /etc/sysconfig/network, so I did that too. What I'm seeing is, when the machine boots, and I log in as root, ypbind is not running, and domainname is set to "(none)". It has been suggested to me that I write a script that does the command "domainname MYDOMAIN" and put it in the startup sequence before xinetd runs (I assume that ypbind is trying to start and craps out because domainname is not set). But I have a problem with that. Isn't the whole point of /etc/yp.conf to specify the domainname in one place on the system? Isn't this supposed to cause the domainname to be set at boot time?

    Thanks for any info...
    The crows maintain that a single crow could destroy the heavens. Doubtless this is so. But it proves nothing against the heavens, for the heavens signify simply: the impossibility of crows.

  2. #2
    Registered User
    Join Date
    Aug 2002
    Location
    Hermosa Beach, CA
    Posts
    446
    Nevermind...I figured it out. Add some code to /etc/rc.d/rc.sysinit.
    The crows maintain that a single crow could destroy the heavens. Doubtless this is so. But it proves nothing against the heavens, for the heavens signify simply: the impossibility of crows.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Socket Programming Problem!!!!
    By bobthebullet990 in forum Networking/Device Communication
    Replies: 2
    Last Post: 02-21-2008, 07:36 PM
  2. WSAAsyncSelect Socket Model. She's Not Hot.
    By Tonto in forum Networking/Device Communication
    Replies: 2
    Last Post: 03-24-2007, 09:34 AM
  3. Client works on a LAN but don't send all the data
    By Niara in forum Networking/Device Communication
    Replies: 9
    Last Post: 01-04-2007, 04:44 PM
  4. Unicode vurses Non Unicode client server application with winsock2 query?
    By dp_76 in forum Networking/Device Communication
    Replies: 0
    Last Post: 05-16-2005, 08:26 AM
  5. Serial Communications in C
    By ExDigit in forum Windows Programming
    Replies: 7
    Last Post: 01-09-2002, 10:52 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21