Installing Knoppix v3.9 to my harddrive....

This is a discussion on Installing Knoppix v3.9 to my harddrive.... within the Tech Board forums, part of the Community Boards category; When I install Knoppix v3.9 onto my harddrive this appears in the terminal Code: knoppix@0[knoppix]$ sudo knoppix-installer /usr/bin/mkdesktophdicons: line 42: ...

  1. #1
    Novice Programmer Pyroteh's Avatar
    Join Date
    Jan 2005
    Location
    Alaska
    Posts
    82

    Installing Knoppix v3.9 to my harddrive....

    When I install Knoppix v3.9 onto my harddrive this appears in the terminal
    Code:
    knoppix@0[knoppix]$ sudo knoppix-installer
    /usr/bin/mkdesktophdicons: line 42: cannot create temp file for here document: Permission denied
    /usr/bin/mkdesktophdicons: line 100: cannot create temp file for here document: Permission denied
    Can't open /mnt/hdinstall/home/adm/.mozilla/default/*/prefs.js: No such file or directory.
    /usr/sbin/alsactl: save_state:1194: No soundcards found...
    In file "/usr/lib/menu/knoppix-gen-kwifi", at (or in the definition that ends at) line 1:
    [...]iFiManager" command="sudo kwifimanager -caption "%c" %i %m  " icon=kwifimanager kderemove="y"
    [...]                                                 ^
    Expected: "="
    Skipping file because of errors...
    knoppix@0[knoppix]$
    is this a bad thing?

    also when I boot up into knoppix from the hard drive... instead of the colorful Knoppix text theres this 'Kanotix (HD-Installation)'

    when I try to login as root theres a pop up that says "Root Logins are not allowed".
    but it lets me use the 'su' command in the terminal

    Thanks for any help....

  2. #2
    Registered User Jaqui's Avatar
    Join Date
    Feb 2005
    Posts
    416
    yup.
    your install didn't set the correct permissions:

    /usr/bin/mkdesktophdicons: line 42: cannot create temp file for here document: Permission denied
    /usr/bin/mkdesktophdicons: line 100: cannot create temp file for here document: Permission denied
    then, it looks like the fstab isn't set right:
    Can't open /mnt/hdinstall/home/adm/.mozilla/default/*/prefs.js: No such file or directory.
    need to run sndconfig tool after fixing first 2 issues:
    /usr/sbin/alsactl: save_state:1194: No soundcards found...
    the rest looks like the .bashrc file is also corrupted.
    did you format the partition before installing?
    it's almost like you installed onto an ntfs partition.

    maybe you could consider using debian, since by installing Knoppix onto the drive that is basically exactly what you are doing.
    Quote Originally Posted by Jeff Henager
    If the average user can put a CD in and boot the system and follow the prompts, he can install and use Linux. If he can't do that simple task, he doesn't need to be around technology.

  3. #3
    Novice Programmer Pyroteh's Avatar
    Join Date
    Jan 2005
    Location
    Alaska
    Posts
    82
    yeah... I basically formatted my harddrive into an ext3 partition before I installed it... I have a Linux-Swap on there too.... its running fine... I got some help over at 'knoppix.net/forum' but my cd-rom and dvd drives don't work.... whenever I put in a disk it doesn't detect and read it....

  4. #4
    Registered User Jaqui's Avatar
    Join Date
    Feb 2005
    Posts
    416
    ahh, automount / autorun stuffs.
    not always reliable for automount.
    and autorun don't exist to speak of.

    It seems to be generally assumed that if you are using linux you will not want your system to start anything without your explicit instructions to do so.
    Quote Originally Posted by Jeff Henager
    If the average user can put a CD in and boot the system and follow the prompts, he can install and use Linux. If he can't do that simple task, he doesn't need to be around technology.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Cheap way to cool down an external harddrive
    By cyberfish in forum Tech Board
    Replies: 13
    Last Post: 06-19-2009, 06:10 PM
  2. Odd harddrive behavior.
    By psychopath in forum Tech Board
    Replies: 6
    Last Post: 04-13-2007, 05:58 PM
  3. Knoppix Help
    By drdodirty2002 in forum Tech Board
    Replies: 2
    Last Post: 01-05-2006, 08:50 AM
  4. Trouble installing Qt3 from book Cd
    By mrcheesypants in forum Tech Board
    Replies: 2
    Last Post: 10-12-2005, 06:57 PM
  5. Installing a HD
    By MethodMan in forum Tech Board
    Replies: 6
    Last Post: 01-16-2003, 05:07 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21