Seems I can't access my CD Driver in DOS mode

This is a discussion on Seems I can't access my CD Driver in DOS mode within the Tech Board forums, part of the Community Boards category; My CD Driver is D:\. I try to access it in DOS the old fashion way, writing "cd D:" , ...

  1. #1
    Registered User
    Join Date
    Dec 2001
    Posts
    367

    Seems I can't access my CD Driver in DOS mode

    My CD Driver is D:\. I try to access it in DOS the old fashion way, writing "cd D:" , because I want to play an old DOS game I have. It seems it can't browse D:\ though. Secondly, the game says the CD ROM is not in the driver at all when it indeed is there. There seems to be some major problem with accessing the D:\ here. Do you know what it may be? I'll attach a screenshot for some further clarification on the problem.
    Attached Images Attached Images  

  2. #2
    Registered User
    Join Date
    Nov 2004
    Location
    India
    Posts
    515
    you just have to say d: and not cd d: ,correct me if i am wrong, long time since i accessed the dos prompt
    Code:
    >+++++++++[<++++++++>-]<.>+++++++[<++++>-]<+.+++++++..+++.[-]>++++++++[<++++>-] <.>+++++++++++[<++++++++>-]<-.--------.+++.------.--------.[-]>++++++++[<++++>- ]<+.[-]++++++++++.

  3. #3
    Registered User
    Join Date
    Dec 2001
    Posts
    367
    Thanks, that helps. But the game still thinks that the CD isn't in the driver.

  4. #4
    Registered /usr
    Join Date
    Aug 2001
    Location
    Newport, South Wales, UK
    Posts
    1,266
    Constructor, eh? I still play that every now and then, even though it's UNIVBE and thus needed a hack to work with a modern video card.

    Also it's got problems working under Windows 2000/XP because a network driver detection routine won't go as planned. If you still want to play it, get DOSBox or make a new partition with an older (pre 2000) version of Windows.

  5. #5
    Registered User
    Join Date
    Dec 2001
    Posts
    367
    Alright! Now the Program is running! Thanks a lot SMurf for the advice of how to get good ol' Constructor running again. DOSBox seems to have helped solving the program's problem of not finding the CD ROM drive.

    Feels like I have dug out some dusty ancient writing that has to be taken through several reconunstructing procedures before its knowledge can be attained.
    Last edited by Zewu; 02-22-2005 at 04:40 PM.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Replies: 0
    Last Post: 07-28-2008, 03:10 AM
  2. Implementing "ls -al"
    By pdstatha in forum Linux Programming
    Replies: 11
    Last Post: 03-20-2002, 03:39 AM
  3. free() usage
    By pdstatha in forum C Programming
    Replies: 5
    Last Post: 03-13-2002, 08:28 AM
  4. Implementing "ls -al"
    By pdstatha in forum C Programming
    Replies: 7
    Last Post: 03-06-2002, 04:36 PM
  5. Text in Dos Graphics Mode
    By Frozen_Solid in forum A Brief History of Cprogramming.com
    Replies: 1
    Last Post: 10-25-2001, 04:16 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21