Working SB Live in Linux?

This is a discussion on Working SB Live in Linux? within the Tech Board forums, part of the Community Boards category; i cant get my sound blaster live card to work under linux. i tried the rpm and the source tarball. ...

  1. #1
    martman00
    Guest

    Working SB Live in Linux?

    i cant get my sound blaster live card to work under linux. i tried the rpm and the source tarball. on start i get a error that device /dev/dsp cant be found, ls shows it and i ran mknod(i might of did wrong flags, can any one tell me what i should of typed?). any ideas?

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    102
    What did you install to get sound.. that would be just JUST A little helpfull

    Also what distro and are you useing devfs?

    What are the prems on /dev/dsp?
    Can you use it as root? As regular user?

  3. #3
    Registered User
    Join Date
    Jul 2002
    Posts
    913
    What did you install to get sound.. that would be just JUST A little helpfull
    i tried everything!!! i want to know if it can be done!!!

    i played with the rpm and the tar ball for the chipset. i later reinstalled alsa. everything compiles fine(i had probelems at first with my smb kernel, but it didnt a recompile and rearranging anyway), but when i log into x it says it cant find /dev/dsp. i can see it with ls. i deleted it and mknod a new one(i looked up the numbers for it) and it still didnt work. then i figured maybe it cant write/read so i check every permission. and i know the card works.

    im completly lost, im new to linux to, that not helping me alot.

    the funny part is, i started in 6.2 and only tried a sound car in 9.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    102
    Ok so you installed ALSA?
    What distro are you using. Did you try the kernel drivers? ARe you using devfs? Have you checked to make sure that the moduels for the sound device are installed? Have you tried OSS? I was having problmes with my chipset but then I got my hands on OSS and it works beautfully. Good enough that I purchased a liscense (normaly I would just setup a cron job to unmute my the card every hour or so).

    What do you get with a lspci? does it show the sound card. Does it appear in the dmesg?

    What tarballs do you mean (give me the name).

    and above all.. remain calm. Think logicaly..
    Also if you really want live help check out irc.xchat.com #linuxhelp
    Im in there sometimes under the same nick

  5. #5
    Registered User
    Join Date
    Jul 2002
    Posts
    913
    im using redhat 9. i recompiled my kernel with the sblive driver in it. the new hardware dection program(something like kudzo) did find the card. im using the file of of http://sourceforge.net/projects/emu10k1/ , emu10k1-v0.20a.tar.bz2.

    i thought devfs was just a template for the stuff in /dev, i already adding all the devices(dsp, audio, mixer).

    i havnt tried oss yet.

  6. #6
    martman00
    Guest
    i tried OSS, it doesnt like my smp kernel. does any one know why that even matters?

  7. #7
    martman00
    Guest
    now i cant change my volume, it says it cant write to the mixer. so i changed the permissions(in x) and checked everything thing and restarted. the same thing, i check for the permissions and x(kde, well redhat bluecurve) didnt save it. why wont anything work?

  8. #8
    Registered User
    Join Date
    Jul 2002
    Posts
    913
    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.
    does any one know what to do?

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Linux distro advice
    By Decrypt in forum A Brief History of Cprogramming.com
    Replies: 16
    Last Post: 08-16-2006, 10:42 AM
  2. Why Linux, for the average user?
    By Hunter2 in forum A Brief History of Cprogramming.com
    Replies: 32
    Last Post: 07-07-2006, 02:36 PM
  3. Port app from Windows to Linux
    By BobS0327 in forum Linux Programming
    Replies: 12
    Last Post: 02-12-2006, 01:35 AM
  4. linux wont boot
    By GanglyLamb in forum Tech Board
    Replies: 4
    Last Post: 02-13-2003, 03:04 PM
  5. Linux X server installation
    By Unregistered in forum Linux Programming
    Replies: 3
    Last Post: 01-18-2002, 01:18 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21