Question on apt-get ?

This is a discussion on Question on apt-get ? within the Tech Board forums, part of the Community Boards category; Why everytime i do a sudo apt-get install build-essential dpkg-dev fakeroot debhelper libgdbm-dev libldap2-dev libpcre3-dev libssl-dev libsasl2-dev postgresql-server-dev-8.2 po-debconf dpatch ...

  1. #1
    POeT GuY Matus's Avatar
    Join Date
    Feb 2008
    Location
    Bz
    Posts
    235

    Question Question on apt-get ?

    Why everytime i do a sudo apt-get install build-essential dpkg-dev fakeroot debhelper libgdbm-dev libldap2-dev libpcre3-dev libssl-dev libsasl2-dev postgresql-server-dev-8.2 po-debconf dpatch libmysqlclient15-dev lsb-release libcdb-dev libdb-dev


    IN the end i get this:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done

    E: Couldn't find package postgresql-server-dev-8.2


    It always says it could find that package, i believe this is exactly why i screwed up squirrel mail last time. and before that i had done the following below and completed successfully.

    sudo apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl postfix-tls libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql libpam-smbpass
    PoEms R InsPiRatiOns of LIfE ExpErienCes!!


  2. #2
    Registered User carrotcake1029's Avatar
    Join Date
    Apr 2008
    Posts
    398
    Which distro are you using?

    postgresql-server-dev-8.2 is not available for some of the newer Ubuntu distros, but I am sure you could still get it to work.

    Ubuntu -- Details of package postgresql-server-dev-8.2 in gutsy

    But once again, this depends on which distro of Linux you are using.

  3. #3
    POeT GuY Matus's Avatar
    Join Date
    Feb 2008
    Location
    Bz
    Posts
    235
    Quote Originally Posted by carrotcake1029 View Post
    Which distro are you using?

    postgresql-server-dev-8.2 is not available for some of the newer Ubuntu distros, but I am sure you could still get it to work.

    Ubuntu -- Details of package postgresql-server-dev-8.2 in gutsy

    But once again, this depends on which distro of Linux you are using.
    I'm on Ubuntu Hardy, I'm currently researchinng but nothing so far


    I'm using this tutorial by the way : http://www.howtoforge.com/virtual-us...ail-ubuntu8.04 on installing squirrel mail
    Last edited by Matus; 03-26-2009 at 10:11 PM.
    PoEms R InsPiRatiOns of LIfE ExpErienCes!!


  4. #4
    Registered User
    Join Date
    Dec 2006
    Location
    Canada
    Posts
    3,183
    Version numbers are usually not part of the package name.

    And I thought Squirrel Mail uses MySQL (I used to run it).

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Alice....
    By Lurker in forum A Brief History of Cprogramming.com
    Replies: 16
    Last Post: 06-20-2005, 03:51 PM
  2. Debugging question
    By o_0 in forum C Programming
    Replies: 9
    Last Post: 10-10-2004, 06:51 PM
  3. Question about pointers #2
    By maxhavoc in forum C++ Programming
    Replies: 28
    Last Post: 06-21-2004, 01:52 PM
  4. Question...
    By TechWins in forum A Brief History of Cprogramming.com
    Replies: 16
    Last Post: 07-28-2003, 10:47 PM
  5. Question, question!
    By oskilian in forum A Brief History of Cprogramming.com
    Replies: 5
    Last Post: 12-24-2001, 01:47 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21