Client/Server problem

This is a discussion on Client/Server problem within the Networking/Device Communication forums, part of the General Programming Boards category; I just made a simple server/client application using Qt but I cant connect the client to the server if it ...

  1. #1
    The Autodidact Dante Wingates's Avatar
    Join Date
    Apr 2010
    Location
    Valhalla
    Posts
    56

    Thumbs down Client/Server problem

    I just made a simple server/client application using Qt but I cant connect the client to the server if it is not on my machine... Using 127.0.0.1 or my IP works, but when I try to connect the client from another machine to the server in my machine, simply does not work.... Its actually a chat, and when I ask another person to connect to my IP address using the client, it does not connect...

    I have already made this kind of thing many times before, and even a similar program about a year ago using C#... It follows the same rules, but simply does not work....


    Any advice would be appreciated... Tell me if you need to see the code

  2. #2
    &TH of undefined behavior Fordy's Avatar
    Join Date
    Aug 2001
    Posts
    5,789
    Does your computer have its firewall enabled - that's the likely problem.

  3. #3
    and the hat of int overfl Salem's Avatar
    Join Date
    Aug 2001
    Location
    The edge of the known universe
    Posts
    32,832
    Perhaps some analysis with wireshark will show you where it's going wrong.

    As would adding error checks to ALL network functions, and printing out what they return on error.
    If you dance barefoot on the broken glass of undefined behaviour, you've got to expect the occasional cut.
    If at first you don't succeed, try writing your phone number on the exam paper.
    I support http://www.ukip.org/ as the first necessary step to a free Europe.

  4. #4
    The Autodidact Dante Wingates's Avatar
    Join Date
    Apr 2010
    Location
    Valhalla
    Posts
    56
    When I talked about the C# application, I thought about using it to see if something was wrong with my network config, because it should work normally, but it didnt... So now its kinda obvious that there is some problem with my network, firewall or whatever...

    I'll try wireshark, but I dont have many clues about what could be wrong... Im not very experienced with network programming, just enough to create server/client applications


    thanks for the help

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Memory problem with Borland C 3.1
    By AZ1699 in forum C Programming
    Replies: 16
    Last Post: 11-16-2007, 11:22 AM
  2. Someone having same problem with Code Block?
    By ofayto in forum C++ Programming
    Replies: 1
    Last Post: 07-12-2007, 09:38 AM
  3. A question related to strcmp
    By meili100 in forum C++ Programming
    Replies: 6
    Last Post: 07-07-2007, 03:51 PM
  4. WS_POPUP, continuation of old problem
    By blurrymadness in forum Windows Programming
    Replies: 1
    Last Post: 04-20-2007, 07:54 PM
  5. RE: client/server shared memory problem
    By hampycalc in forum C Programming
    Replies: 0
    Last Post: 03-10-2006, 02:26 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21