why can't build project in KDevelop C/C++

This is a discussion on why can't build project in KDevelop C/C++ within the Linux Programming forums, part of the Platform Specific Boards category; Hi, I'm just starting to program in linux (openSuse 10.2), trying to use KDevelop C/C++, but I even can't build ...

  1. #1
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14

    why can't build project in KDevelop C/C++

    Hi, I'm just starting to program in linux (openSuse 10.2), trying to use KDevelop C/C++, but I even can't build a sample project. That is what I get:
    cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && CXXFLAGS="-O0 -g3" "/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/configure" --enable-debug=full && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k
    This Makefile is only for the CVS repository
    This will be deleted before making the distribution
    <br />
    ./admin/cvs.sh: ./admin/detect-autoconf.pl: /usr/bin/env: bad interpreter: Permission denied
    ./admin/cvs.sh: line 33: --version: command not found
    *** AUTOCONF NOT FOUND!.
    *** KDE requires autoconf 2.53 or newer
    gmake[1]: *** [cvs] Error 1
    gmake: *** [all] Error 2
    *** Exited with status: 2 ***

  2. #2
    Captain Crash brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,235
    Quote Originally Posted by Lauris View Post
    Hi, I'm just starting to program in linux (openSuse 10.2), trying to use KDevelop C/C++, but I even can't build a sample project. That is what I get:
    You need to install the "autoconf" tool. The error is pretty clear.

    EDIT: Actually, wait. I think it's failing to find autoconf for some other reason. Look at this line:

    Code:
    ./admin/cvs.sh: ./admin/detect-autoconf.pl: /usr/bin/env: bad interpreter: Permission denied
    Looks like you have a messed up /usr/bin/env. Do you have Perl installed? What does the very first line of the ./admin/detect-autoconf.pl file look like?

  3. #3
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    Quote Originally Posted by brewbuck View Post
    Looks like you have a messed up /usr/bin/env. Do you have Perl installed? What does the very first line of the ./admin/detect-autoconf.pl file look like?

    first line of th ./admin/detect-autoconf.pl file:
    Code:
    #!/usr/bin/env perl

  4. #4
    Captain Crash brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,235
    Quote Originally Posted by Lauris View Post
    first line of th ./admin/detect-autoconf.pl file:
    Code:
    #!/usr/bin/env perl
    Try changing that line to:

    Code:
    #!/usr/bin/perl
    And see if that changes anything.

    It looks like your installation of /usr/bin/env is broken somehow. Does the file /usr/bin/env even exist? Is it marked executable?

  5. #5
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    Quote Originally Posted by brewbuck View Post
    Try changing that line to:

    Code:
    #!/usr/bin/perl
    And see if that changes anything.

    It looks like your installation of /usr/bin/env is broken somehow. Does the file /usr/bin/env even exist? Is it marked executable?
    after changing
    Code:
    #!/usr/bin/env perl
    to
    Code:
    #!/usr/bin/perl
    results are the same:
    cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && CXXFLAGS="-O0 -g3" "/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/configure" --enable-debug=full && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k
    This Makefile is only for the CVS repository
    This will be deleted before making the distribution
    <br />
    ./admin/cvs.sh: ./admin/detect-autoconf.pl: /usr/bin/perl: bad interpreter: Permission denied
    ./admin/cvs.sh: line 33: --version: command not found
    *** AUTOCONF NOT FOUND!.
    *** KDE requires autoconf 2.53 or newer
    gmake[1]: *** [cvs] Error 1
    gmake: *** [all] Error 2
    *** Exited with status: 2 ***
    in usr/bin file env and file perl exist, and looks like executable...

  6. #6
    Captain Crash brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,235
    Can you give the precise output of:

    ls -la /usr/bin/env /usr/bin/perl

  7. #7
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    Quote Originally Posted by brewbuck View Post
    Can you give the precise output of:

    ls -la /usr/bin/env /usr/bin/perl
    Code:
    linux-9mwq:~ # ls -la /usr/bin/env /usr/bin/perl
    -rwxr-xr-x 1 root root   18872 Nov 25  2006 /usr/bin/env
    -rwxr-xr-x 3 root root 1163988 Nov 25  2006 /usr/bin/perl

  8. #8
    Captain Crash brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,235
    Quote Originally Posted by Lauris View Post
    Code:
    linux-9mwq:~ # ls -la /usr/bin/env /usr/bin/perl
    -rwxr-xr-x 1 root root   18872 Nov 25  2006 /usr/bin/env
    -rwxr-xr-x 3 root root 1163988 Nov 25  2006 /usr/bin/perl
    I'm at a loss, unfortunately. It looks okay.

    Try putting the line:

    set -x

    At the very top of the ./admin/cvs.sh file. This will cause it to spew out a LOAD of information which might help.

  9. #9
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    Quote Originally Posted by brewbuck View Post
    I'm at a loss, unfortunately. It looks okay.

    Try putting the line:

    set -x

    At the very top of the ./admin/cvs.sh file. This will cause it to spew out a LOAD of information which might help.
    well, not much use of that, still erors and it looks like that now:
    cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && CXXFLAGS="-O0 -g3" "/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/configure" --enable-debug=full && cd '/usr/win/D/Mokslai/IIsIIk/PrPr/001/bnd/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k
    This Makefile is only for the CVS repository
    This will be deleted before making the distribution
    <br />
    + unset MAKEFLAGS
    + LC_ALL=C
    + export LC_ALL
    + unset LANG
    + unset LC_CTYPE
    + unset LANGUAGE
    + unset CDPATH
    ++ echo ./admin/cvs.sh
    ++ sed 's%[\/][^\/][^\/]*$%%'
    + admindir=./admin
    + test x./admin = x./admin/cvs.sh
    + test xgmake = x
    + makefile_am=Makefile.am
    + makefile_wo=Makefile.am.wo
    + test -f Makefile.am.in
    ++ ./admin/detect-autoconf.pl
    ./admin/cvs.sh: ./admin/detect-autoconf.pl: /usr/bin/perl: bad interpreter: Permission denied
    + eval
    ++ echo cvs
    ++ tr .- __
    + arg=cvs
    + case $arg in
    + cvs
    + check_autotool_versions
    + required_autoconf_version='2.53 or newer'
    ++ --version
    ./admin/cvs.sh: line 34: --version: command not found
    ++ head -n 1
    + AUTOCONF_VERSION=
    + case $AUTOCONF_VERSION in
    + echo '*** AUTOCONF NOT FOUND!.'
    *** AUTOCONF NOT FOUND!.
    + echo '*** KDE requires autoconf 2.53 or newer'
    *** KDE requires autoconf 2.53 or newer
    + exit 1
    gmake[1]: *** [cvs] Error 1
    gmake: *** [all] Error 2
    *** Exited with status: 2 ***

  10. #10
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    maybe in cvs.sh flile something is wrong, this scrap of code is somewhere about 34line and has something similar to error mesage:
    Code:
    check_autotool_versions()
    {
    required_autoconf_version="2.53 or newer"
    AUTOCONF_VERSION=`$AUTOCONF --version | head -n 1`
    case $AUTOCONF_VERSION in
      Autoconf*2.5* | autoconf*2.5* | autoconf*2.6* ) : ;;
      "" )
        echo "*** AUTOCONF NOT FOUND!."
        echo "*** KDE requires autoconf $required_autoconf_version"
        exit 1
        ;;
      * )
        echo "*** YOU'RE USING $AUTOCONF_VERSION."
        echo "*** KDE requires autoconf $required_autoconf_version"
        exit 1
        ;;
    esac

  11. #11
    Captain Crash brewbuck's Avatar
    Join Date
    Mar 2007
    Location
    Portland, OR
    Posts
    7,235
    Quote Originally Posted by Lauris View Post
    maybe in cvs.sh flile something is wrong, this scrap of code is somewhere about 34line and has something similar to error mesage:
    Yes, but I think the real problem is here:

    ++ ./admin/detect-autoconf.pl
    ./admin/cvs.sh: ./admin/detect-autoconf.pl: /usr/bin/perl: bad interpreter: Permission denied
    It's not even able to launch the script which tries to detect autoconf...

  12. #12
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    but what can be wrong with it??? permisions are right, I'm runing ir root user and root with both files can do everything...

  13. #13
    Crazy Fool Perspective's Avatar
    Join Date
    Jan 2003
    Location
    Canada
    Posts
    2,640
    Try updating your auto-tools installation.

  14. #14
    Registered User
    Join Date
    Mar 2007
    Location
    Kaunas, Lithuania
    Posts
    14
    Quote Originally Posted by Perspective View Post
    Try updating your auto-tools installation.
    how and from where to get it???

  15. #15
    Crazy Fool Perspective's Avatar
    Join Date
    Jan 2003
    Location
    Canada
    Posts
    2,640
    Your linux distro should have an update tool. I'm not sure what suse uses, it's rpm based but they likely have some sort of tool on top of that (maybe yum?). try rpm --update automake or something like that.

Page 1 of 2 12 LastLast
Popular pages Recent additions subscribe to a feed

Similar Threads

  1. MFC in an empty project
    By cunnus88 in forum Windows Programming
    Replies: 0
    Last Post: 10-09-2005, 09:19 AM
  2. Game Independent Anti-cheat Project Needs Programmers
    By GIA Project Lea in forum Projects and Job Recruitment
    Replies: 3
    Last Post: 09-15-2005, 07:41 PM
  3. How do I fix this error?
    By BigMac in forum C++ Programming
    Replies: 8
    Last Post: 12-14-2003, 03:32 AM
  4. I Need The Simplest Tutorial Out there.
    By yakabod in forum C++ Programming
    Replies: 8
    Last Post: 08-14-2003, 12:33 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21