KDevelop + Allegro... not working

This is a discussion on KDevelop + Allegro... not working within the Linux Programming forums, part of the Platform Specific Boards category; I've just installed the latest stable version of Allegro (4.0.9 i believe), using the 'ol tarball (./configure, make, make install). ...

  1. #1
    Registered User
    Join Date
    Aug 2001
    Posts
    244

    KDevelop + Allegro... not working

    I've just installed the latest stable version of Allegro (4.0.9 i believe), using the 'ol tarball (./configure, make, make install).

    Since I'm running Mandrake 9.0, I moved the libs and includes from /usr/local/lib and /usr/local/include to /usr/lib and /usr/include, since thats where Mandrake likes them.

    I also added /usr/lib to /etc/ld.so.conf (which may not have been necessary), and ran ldconfig.

    BUT in KDevelop, compiling fails because of dozens of undefined references. It can't find the allegro files for some reason.

    Is there a compiling option I should add, or a file I need to edit?

    Thanks.!

  2. #2
    geek SilentStrike's Avatar
    Join Date
    Aug 2001
    Location
    NJ
    Posts
    1,141
    Did you try to add allegro to the linking option?
    Prove you can code in C++ or C# at TopCoder, referrer rrenaud
    Read my livejournal

  3. #3
    Registered User
    Join Date
    Aug 2001
    Posts
    244
    running allegro-config --libs (and --shared)gives me:
    -L/usr/lib -L/usr/X11R6/lib -Wl,-export-dynamic -lalleg-4.0.2 -lalleg_unsharable

    allegro-config --cflags (and --cppflags)gives me:
    -I/usr/include

    allegro-config --static gives:
    -L/usr/lib -L/usr/X11R6/lib -Wl,-export-dynamic -lalleg -lm -lpthread -lXxf86dga -lXxf86vm -lXext -lX11 -ldl

    allegro-config --env gives:
    export PATH=$PATH:/usr/bin
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib
    export LIBRARY_PATH=$LIBRARY_PATH:/usr/lib
    export C_INCLUDE_PATH=$C_INCLUDE_PATH:/usr/include
    export CPLUS_INCLUDE_PATH=$CPLUS_INCLUDE_PATH:/usr/include
    export OBJC_INCLUDE_PATH=$OBJC_INCLUDE_PATH:/usr/include


    I read on the Allegro mailing list that I need to add some of those lines to the compiler options in KDevelop.. and well I've tried to no avail. I tried what I thought would be correct, and a few other things that I think might have been correct, but none worked. I've also seen people adding "allegro-config --libs" to the linker options, to no avail for me.

    Thanks for the reply!

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Replies: 8
    Last Post: 05-07-2009, 12:31 PM
  2. dev & allegro compile errors
    By Calgore in forum C++ Programming
    Replies: 10
    Last Post: 08-11-2004, 05:41 PM
  3. need help fixing up this code in allegro
    By Bobish in forum Game Programming
    Replies: 11
    Last Post: 04-06-2002, 02:50 PM
  4. installing allegro
    By rkjd2 in forum C++ Programming
    Replies: 0
    Last Post: 03-26-2002, 12:29 PM
  5. Allegro
    By The15th in forum A Brief History of Cprogramming.com
    Replies: 0
    Last Post: 09-14-2001, 04:06 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21