Arch Linux, first install issues!

This is a discussion on Arch Linux, first install issues! within the Linux Programming forums, part of the Platform Specific Boards category; So I have been at this all morning and I am ready to smash my laptop with a sledge hammer. ...

  1. #1
    Registered User Annonymous's Avatar
    Join Date
    Apr 2011
    Location
    Jackson, New Jersey, United States
    Posts
    302

    Arch Linux, first install issues!

    So I have been at this all morning and I am ready to smash my laptop with a sledge hammer. Just teasing y'all cuz I know how much y'all want to see that!

    Seriously though, this is aggregating! I started with a bsdcpio error that was fixed by using the core install instead of the netinstall version. Then I was getting an error about address space collission that I aslo permanently fixed by appending pci=nocrs to my menu.conf in my boot folder. Now I only receive a udev error. The biggest issue is I have to manually mount my hard drive with a live CD because I am dropped into a limited recovery shell if I boot straight from the HDD. I can see the partitions when I use blkid or mount or even when I use ls /dev | grep "^sd".

    Can someone please freaking help me!

  2. #2
    Registered User Annonymous's Avatar
    Join Date
    Apr 2011
    Location
    Jackson, New Jersey, United States
    Posts
    302
    Figured it out.

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    2,370
    please share your solution with the rest of us, so that others who have this problem may benefit as well.

  4. #4
    Registered User Annonymous's Avatar
    Join Date
    Apr 2011
    Location
    Jackson, New Jersey, United States
    Posts
    302
    On boot I realized my laptop was looking for an sda partition. I manually mounted my hard drive from the CD and changed fstab entries from sdb to sda and it booted.

  5. #5
    Registered User Annonymous's Avatar
    Join Date
    Apr 2011
    Location
    Jackson, New Jersey, United States
    Posts
    302
    I forgot to mention I added usb to the hooks param in mkinitcpio.conf It's needed in order to boot from an external hard drive or USB.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Linux install
    By MadCow257 in forum Tech Board
    Replies: 13
    Last Post: 02-18-2005, 01:35 PM
  2. Linux install
    By moi in forum Tech Board
    Replies: 0
    Last Post: 12-08-2002, 09:35 AM
  3. trying to install linux
    By task in forum Linux Programming
    Replies: 19
    Last Post: 10-28-2002, 08:42 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21