Application has failed to start?

This is a discussion on Application has failed to start? within the Game Programming forums, part of the General Programming Boards category; I'm trying to port my editor code into msvc .net 05 and it won't start the app from the IDE ...

  1. #1
    Super Moderator VirtualAce's Avatar
    Join Date
    Aug 2001
    Posts
    9,590

    Application has failed to start?

    I'm trying to port my editor code into msvc .net 05 and it won't start the app from the IDE or from the command line.

    I've looked this error message up and it seems it cannot find vc80 runtime.

    I have no idea how to fix this. Perhaps I must re-compile the MSVC 6 engine dll with 05?

    Thanks MS for once again making porting existing applications into your ........ a pain in the ass.

    Read this mess

    http://www.codeproject.com/cpp/vcred...6.asp#MFCSpecs
    Last edited by VirtualAce; 05-07-2006 at 03:00 PM.

  2. #2
    erstwhile
    Join Date
    Jan 2002
    Posts
    2,227
    >>it cannot find a vc80 runtimes<<

    You need to distribute the Microsoft Visual C++ 2005 Redistributable Package (x86) with your applications - or statically link your builds.
    CProgramming FAQ
    Caution: this person may be a carrier of the misinformation virus.

  3. #3
    Super Moderator VirtualAce's Avatar
    Join Date
    Aug 2001
    Posts
    9,590
    It doesnt even work for testing.

    I can't get anything to work.

  4. #4
    erstwhile
    Join Date
    Jan 2002
    Posts
    2,227
    Sorry, I misread your post. You should have all the relevant dll's in your %windir%\winsxs directory after installing vc2005.

    Not sure if this is relevant but rebuilding the dll might be necessary:
    Quote Originally Posted by msdn2
    If your DLLs pass CRT resources across the msvcrt.dll and msvcr80.dll boundary, you will encounter issues with mismatched CRTs and need to recompile your project with Visual C++ 2005.
    More here:

    http://msdn2.microsoft.com/en-US/library/abx4dbyh.aspx
    CProgramming FAQ
    Caution: this person may be a carrier of the misinformation virus.

  5. #5
    Super Moderator VirtualAce's Avatar
    Join Date
    Aug 2001
    Posts
    9,590
    Ok yeah they are all there so why doesn't it run?

    I rebuilt the DLL under MSVC 2005 and put the lib in the project folder and the dll in the debug folder where the debug exe is. Still no go.

  6. #6
    Super Moderator VirtualAce's Avatar
    Join Date
    Aug 2001
    Posts
    9,590
    Problem solved.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Problem with com application
    By amardon in forum C++ Programming
    Replies: 3
    Last Post: 10-06-2005, 05:50 AM
  2. cannot start a parameter declaration
    By Dark Nemesis in forum C++ Programming
    Replies: 6
    Last Post: 09-23-2005, 02:09 PM
  3. porting application from 32 bit to 64 bit error
    By gandalf_bar in forum Linux Programming
    Replies: 1
    Last Post: 09-14-2005, 09:20 AM
  4. Win application not very portable
    By swed in forum Windows Programming
    Replies: 5
    Last Post: 10-01-2001, 11:17 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21