allegro installation problems on dev-c++

This is a discussion on allegro installation problems on dev-c++ within the Game Programming forums, part of the General Programming Boards category; I'm trying to install allegro on the latest dev-c++. The actual allegro bit went ok, but I'm getting weird linker ...

  1. #1
    GA ichijoji's Avatar
    Join Date
    Nov 2002
    Posts
    179

    allegro installation problems on dev-c++

    I'm trying to install allegro on the latest dev-c++. The actual allegro bit went ok, but I'm getting weird linker errors:
    [Linker error] undefined reference to `endl(ostream &)'
    [Linker error] undefined reference to `cerr'
    [Linker error] undefined reference to `ostream:perator<<(char const *)'
    I can't think of any reason it would be having trouble linking standard library stuff like this. Did I mess up some include path settings or what?
    Illusion and reality become impartiality and confidence.

  2. #2
    i dont know Vicious's Avatar
    Join Date
    May 2002
    Posts
    1,200
    That stuff wont work with allegro.

    Allegro comes with text output functions, and as far as input... Its pretty simple to make your own, or you can download extended libraries.
    What is C++?

  3. #3
    GA ichijoji's Avatar
    Join Date
    Nov 2002
    Posts
    179
    The only standard library that I was using was <fstream>, and that's always worked before. Is it not supposed to?
    Illusion and reality become impartiality and confidence.

  4. #4
    Super Moderator
    Join Date
    Sep 2001
    Posts
    4,913
    That stuff wont work with allegro.
    No it won't. Like Vicious said, it's all sort of "over-written" with Allegro. Try using the Allegro functions instead.

  5. #5
    Rambling Man
    Join Date
    Jan 2002
    Posts
    1,050
    " #include <fstream> " can be used with Allegro as long as you are declaring " using namespace std; ". Looking back on some code I had from a long time ago, <fstream> is exactly what I used. So if it's not the using namespace std problem it could be something entirely different.

  6. #6
    GA ichijoji's Avatar
    Join Date
    Nov 2002
    Posts
    179
    I'm using namespace std in my code. This seems to happen every couple installs with me. Could I have written over some library functions or path settings when I was installing?
    Illusion and reality become impartiality and confidence.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. two dev-c++ problems
    By ichijoji in forum C++ Programming
    Replies: 3
    Last Post: 07-07-2004, 02:26 PM
  2. Does allegro work on dev c++?
    By willgell in forum Game Programming
    Replies: 3
    Last Post: 12-13-2002, 11:44 PM
  3. allegro + dev
    By Klinerr1 in forum C++ Programming
    Replies: 1
    Last Post: 06-24-2002, 03:03 AM
  4. allegro
    By |deep| in forum Game Programming
    Replies: 7
    Last Post: 06-15-2002, 04:57 PM
  5. allegro @ msvc
    By dune911 in forum C Programming
    Replies: 4
    Last Post: 10-20-2001, 02:35 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21