debug problem

This is a discussion on debug problem within the Game Programming forums, part of the General Programming Boards category; hi im using allegro with msvc++ i got a problem in my game, it crashes at start so i tried ...

  1. #1
    Registered User
    Join Date
    Dec 2001
    Posts
    479

    debug problem

    hi im using allegro with msvc++
    i got a problem in my game, it crashes at start
    so i tried debuging it. the problem is that the debuger doesnt show the error in the sourcecode.i remember i could view the source in the past. anyone know how to change settings so it works like before
    thx

  2. #2
    Shadow12345
    Guest
    umm, go to build, start debug, then GO, then it will run into a problem. There will be a little window that says 'call stack', you have to pick the proper view so that it shows where in your code it branched off and hit the problem. This might mean going back a few windows, because typically it will show the exact assembly of what went wrong, but if you go to the C++ code it will often be something like, oh, say, accessing memory that doesn't exist or is corrupt.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Replies: 5
    Last Post: 11-07-2005, 11:34 PM
  2. searching problem
    By DaMenge in forum C Programming
    Replies: 9
    Last Post: 09-12-2005, 02:04 AM
  3. half ADT (nested struct) problem...
    By CyC|OpS in forum C Programming
    Replies: 1
    Last Post: 10-26-2002, 09:37 AM
  4. binary tree problem - help needed
    By sanju in forum C Programming
    Replies: 4
    Last Post: 10-16-2002, 06:18 AM
  5. Help, Debug Problem
    By drdroid in forum C++ Programming
    Replies: 3
    Last Post: 02-26-2002, 03:50 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21