opengl Nehe tutorial errors when compiling

This is a discussion on opengl Nehe tutorial errors when compiling within the Game Programming forums, part of the General Programming Boards category; Hi I was interested in learning Opengl and I heard Nehe's tutorials were good. so i typed in what he ...

  1. #1
    Registered User gell10's Avatar
    Join Date
    Jul 2003
    Posts
    46

    opengl Nehe tutorial errors when compiling

    Hi I was interested in learning Opengl and I heard Nehe's tutorials were good. so i typed in what he had and i built it, i got 15 errors and to make sure that it was'nt typing errors i copied and pasted the source code and i still had 15 building errors. I am using visual C++ 6.0 and i have attached a screen shot of what i am seeing. If anyone knows what i am doing wrong please tell me.
    -Thank you everyone.

  2. #2
    Registered User codingmaster's Avatar
    Join Date
    Sep 2002
    Posts
    309
    you haven't attached the sreen shot

    When you copy the code.....

    You have to put it into the main window, which you create with the winAPI....

    It think, that you just copied the code, without having the code for the window.....

  3. #3
    Registered User gell10's Avatar
    Join Date
    Jul 2003
    Posts
    46
    ok well i did what you said and now i have only 1 error it says


    c:\program files\microsoft visual studio\myprojects\new2\ds.cpp(404) : fatal error C1010: unexpected end of file while looking for precompiled header directive
    Error executing cl.exe.

    heres a screen shot of the old problem
    pointlessinformation.com/error.jpg

  4. #4
    I lurk
    Join Date
    Aug 2002
    Posts
    1,361
    Originally posted by gell10
    ok well i did what you said and now i have only 1 error it says


    c:\program files\microsoft visual studio\myprojects\new2\ds.cpp(404) : fatal error C1010: unexpected end of file while looking for precompiled header directive
    Error executing cl.exe.

    heres a screen shot of the old problem
    pointlessinformation.com/error.jpg
    Do a search... I alone have answered this same question at least 5 times. Look here.

  5. #5
    Registered User gell10's Avatar
    Join Date
    Jul 2003
    Posts
    46
    ok i figured it out, i had to go projects->settings->link and then i added the open gl library's. thank you coding master and eibro, both the things you suggested i was also doing wrong. thanks

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Screwy Linker Error - VC2005
    By Tonto in forum C++ Programming
    Replies: 5
    Last Post: 06-19-2007, 03:39 PM
  2. Compiling OpenGL (GLUT) on Linux
    By Unregistered in forum Linux Programming
    Replies: 1
    Last Post: 04-02-2002, 01:38 PM
  3. I get errors, but not from compiling
    By Leeman_s in forum C++ Programming
    Replies: 1
    Last Post: 01-20-2002, 02:07 PM
  4. Compiling errors
    By Olland in forum C Programming
    Replies: 1
    Last Post: 01-08-2002, 05:54 AM
  5. stupid errors i got after compiling!! HELP ME!
    By Leeman_s in forum C++ Programming
    Replies: 1
    Last Post: 10-01-2001, 05:13 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21