possible cause for anomaly (texture)

This is a discussion on possible cause for anomaly (texture) within the Game Programming forums, part of the General Programming Boards category; I'm really not sure what could be causing this. My texture generation code is basically the same as GT's and ...

  1. #1
    Banned
    Join Date
    Jan 2003
    Posts
    1,708

    possible cause for anomaly (texture)

    I'm really not sure what could be causing this. My texture generation code is basically the same as GT's and I'm using the multitexturing GL extensions as well.

    HmmMmm.
    Last edited by Silvercord; 05-14-2003 at 06:01 AM.

  2. #2
    Pursuing knowledge confuted's Avatar
    Join Date
    Jun 2002
    Posts
    1,916
    you might want to explain your exact problem a little better...I know I can't help you with this, but I can't even figure out what's wrong. You also might want to link that image off site..it's pretty big.

    Edit: Actually, I just did it for you...you can delete the picture and hog 0catch's bandwidth now instead of cprogs
    http://confuted.0catch.com/silvercordspic.html
    Last edited by confuted; 05-13-2003 at 07:43 PM.
    Away.

  3. #3
    Banned
    Join Date
    Jan 2003
    Posts
    1,708
    thanks black

  4. #4
    Registered User Coder's Avatar
    Join Date
    Aug 2001
    Location
    Cairo, Egypt
    Posts
    128
    Is that a sky texture or what?

    Anyway, you're generating the texture. So, a good way to know whether the problem's in generating the texture or applying/rendering_stuff_with_it_on_top is to dump the texture you generated to some image file and view it.

    I know I didn't say a lot of useful stuff, but then neither did you
    Proper input results in proper feedback

  5. #5
    Banned
    Join Date
    Jan 2003
    Posts
    1,708
    yeah, umm, ok, I was hoping I would get feedback from someone who had actually done more than I did...anyway the problem has to do with the fact that these quake3 targa files are TGA_RLE which is a compression format...I converted all of the targas to bmps and that means that the problem either lies in:

    1) converting from TGA_RLE to .bmp in photoshop (which i doubt is the problem)
    or
    2) (most likely the actual cause of the problem) i'm ignoring the alpha channel and always assuming 24 bit bitmaps.

    Oh well, I'm closer than I was a while ago and I'll figure all of this out.

    I'm reading up on the tga format right now from GT and I'm goign to write my own tga loader so this stuff workxs all of the time
    Last edited by Silvercord; 05-16-2003 at 08:37 AM.

  6. #6
    'AlHamdulillah
    Join Date
    Feb 2003
    Posts
    790
    I know your exact problem, as i had it when i was first trying out multitexturing, your problem: you coloring the texture with glColor3f by accident. Its a wierd thing to, I dont know a solve to it, except to render it before hand, before you do other stuff.

  7. #7
    Banned
    Join Date
    Jan 2003
    Posts
    1,708
    no, its not, i already specififed the problem: its using a TGA_RLE compressed targa as a bitmap...none of the glcolor commands are anywhere in my code because nothing is rendered with solid color...just textures

  8. #8
    'AlHamdulillah
    Join Date
    Feb 2003
    Posts
    790
    hmm, have you tried using a different texture to replace the current one to determine if maybe some of the information is messed up in the targa?

  9. #9
    Banned
    Join Date
    Jan 2003
    Posts
    1,708
    ...

    writing a targa loader should fix it and make things happy...nada mas

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. d3d9 c++ texture wrapper... again...
    By yaya in forum Game Programming
    Replies: 0
    Last Post: 04-01-2009, 01:08 PM
  2. D3d Texture Wrapper == ARRRGGGGHHH
    By yaya in forum Game Programming
    Replies: 1
    Last Post: 03-25-2009, 06:41 PM
  3. Replies: 4
    Last Post: 02-27-2008, 02:10 PM
  4. OpenGL - look trough surface -nehe lesson
    By GanglyLamb in forum Game Programming
    Replies: 8
    Last Post: 08-24-2006, 11:06 PM
  5. Pong is completed!!!
    By Shamino in forum Game Programming
    Replies: 11
    Last Post: 05-26-2005, 10:50 AM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21