OpenGL texture mapping problems.

This is a discussion on OpenGL texture mapping problems. within the Game Programming forums, part of the General Programming Boards category; Okay, I've sweated through this problem, and still don't know why this is happening. I come to the wisdom of ...

  1. #1
    KnightSword
    Guest

    Exclamation OpenGL texture mapping problems.

    Okay, I've sweated through this problem, and still don't know why this is happening. I come to the wisdom of the board for aid and love. :-D

    I am writing my own little game demo thingie, and I use Lightwave 3D for my modeling. The model format is horrific, but I just chock that up to perfecting my code abilities. And after one false start, I managed to strip off point, polygon, and texture points off the file. (yay) However, when I go to draw the model, the texture mapping is reversed. The image on every face is flipped, making text looking backwards. I double checked my vertex and polygon data to make sure everything lines up properly and it does. The only thing I can think of is that my winding order is reversed, but is there something else I am missing?

    Thanks in advance for all your help.

    KnightSword

  2. #2
    Has a Masters in B.S.
    Join Date
    Aug 2001
    Posts
    2,267
    >The model format is horrific

    yes, genuis, but horrific to load.

    >The only thing I can think of is that my winding order is reversed, but is there something else I am missing?

    this s what i though of first, Lightwave uses a Counter Clockwise Windind(CCW), im working on a "complete" loader myself and haven't quite gotten to textures yet, and its all preliminaty code now but i'll try and remember to get back to you when i finish with the texture loading.
    ADVISORY: This users posts are rated CP-MA, for Mature Audiences only.

  3. #3
    Has a Masters in B.S.
    Join Date
    Aug 2001
    Posts
    2,267
    first a correction,

    Lightwave uses a Clockwise Windind(CW).

    second i've finised texture use except for VMAD's in the display code, which i hope to implement soon, so have you fixed the problem? or you still need some help.
    Last edited by no-one; 07-12-2002 at 10:39 PM.
    ADVISORY: This users posts are rated CP-MA, for Mature Audiences only.

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. d3d9 c++ texture wrapper... again...
    By yaya in forum Game Programming
    Replies: 0
    Last Post: 04-01-2009, 01:08 PM
  2. D3d Texture Wrapper == ARRRGGGGHHH
    By yaya in forum Game Programming
    Replies: 1
    Last Post: 03-25-2009, 06:41 PM
  3. Why only 32x32? (OpenGL) [Please help]
    By Queatrix in forum Game Programming
    Replies: 2
    Last Post: 01-23-2006, 01:39 PM
  4. texture problems with OpenGL
    By jverkoey in forum Game Programming
    Replies: 3
    Last Post: 04-29-2004, 05:50 PM
  5. Adding bitmap as a resource for texture mapping in OpenGL
    By Unregistered in forum Game Programming
    Replies: 2
    Last Post: 03-03-2002, 01:03 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21