some problem with glpng

This is a discussion on some problem with glpng within the Game Programming forums, part of the General Programming Boards category; Hi, i have a problem with glpng, i cant get it to work =)..but i only get 1 error. Code: ...

  1. #1
    Registered User
    Join Date
    Aug 2007
    Posts
    14

    some problem with glpng

    Hi, i have a problem with glpng, i cant get it to work =)..but i only get 1 error.

    Code:
    1>------ Build started: Project: dsf, Configuration: Debug Win32 ------
    1>Compiling...
    1>cl : Command line warning D9035 : option 'Wp64' has been deprecated and will be removed in a future release
    1>main.cpp
    1>c:\users\desktop\ny mapp (2)\main.cpp(9) : fatal error C1083: Cannot open include file: 'gl/glpng.h': No such file or directory
    1>Build log was saved at "file://c:\Users\Desktop\Ny mapp (2)\Debug\BuildLog.htm"
    1>dsf - 1 error(s), 1 warning(s)
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
    I have include both the lib directory and the include directory. (the glpng.h is insude the include directory)
    but it still say that it cant find the glpng.h file.
    Should i link it or something to get it to work?
    Or what could might be the problem?
    (i use Visual C++ 2008 express..)

    //ty in advace

  2. #2
    Kernel hacker
    Join Date
    Jul 2007
    Location
    Farncombe, Surrey, England
    Posts
    15,677
    Seems like you are not specifying the right include directory for your project. Note that you should give the directory that contains the gl directory, not the directory that contains glpng.h.

    E.g. if your file lives here:
    c:/myapps/OpenGL/V1.2/include/gl/glpng.h
    then you should give:
    c:/myapps/OpenGL/V1.2/include
    as the include directory.

    --
    Mats
    Compilers can produce warnings - make the compiler programmers happy: Use them!
    Please don't PM me for help - and no, I don't do help over instant messengers.

  3. #3
    Registered User
    Join Date
    Aug 2007
    Posts
    14
    Thx, now it doesn't say anything about the glpng.lib anymore, but when i did as you sad, i get another error.. have no idea what this lib are..

    Code:
    1>------ Build started: Project: dsf, Configuration: Debug Win32 ------
    1>Compiling...
    1>cl : Command line warning D9035 : option 'Wp64' has been deprecated and will be removed in a future release
    1>main.cpp
    1>Linking...
    1>LINK : fatal error LNK1104: cannot open file 'libcd.lib'
    1>Build log was saved at "file://c:\Users\Desktop\Ny mapp (2)\Debug\BuildLog.htm"
    1>dsf - 1 error(s), 1 warning(s)
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
    Hope anyone can help me solve this problem.

    //ty in advace

  4. #4
    Kernel hacker
    Join Date
    Jul 2007
    Location
    Farncombe, Surrey, England
    Posts
    15,677
    I have NO IDEA what libcd.lib is - so I can't really recommend a way to solve that.

    Perhaps you can search your disk(s) for it, either using explorer or in a comand prompt to "dir /s/b \libcd.lib"

    Assuming it comes up with something like:
    c:\blah\cdcomponent\lib\libcd.dll
    you should add the path to either the link commend, or to the "Library path" in your projects path settings.

    --
    Mats
    Compilers can produce warnings - make the compiler programmers happy: Use them!
    Please don't PM me for help - and no, I don't do help over instant messengers.

  5. #5
    Registered User
    Join Date
    Aug 2007
    Posts
    14
    I have checked a little about the libcd.lib, i think that libcd.lib is integrate in the IDE, so that you cant find it on your computer.
    So i have no idea how to fix my problem =(

    If someone have an idea, how to fix it, please reply.

    //Thanks

  6. #6
    Kernel hacker
    Join Date
    Jul 2007
    Location
    Farncombe, Surrey, England
    Posts
    15,677
    If it's part of the IDE, then it's still supposed to be a FILE somewhere on your system. But if you can't find it, then there are two possible causes:
    1. It's not part of the IDE, and thus you need to get the libcd package installed to your machine.
    2. Your IDE installation is not complete.

    --
    Mats
    Compilers can produce warnings - make the compiler programmers happy: Use them!
    Please don't PM me for help - and no, I don't do help over instant messengers.

  7. #7
    Registered User
    Join Date
    Aug 2007
    Posts
    14
    Hi, and thx for the fast replays.
    I found the problem.. this is what i did:

    project properties- > configuration properties -> linker->input->ignore specific library
    and wrote libcd.lib

    and then i changed the:

    project properties- > configuration properties -> code generation -> Runetime Library
    to Multi-threded Debug (/Mtd).

Popular pages Recent additions subscribe to a feed

Similar Threads

  1. Memory problem with Borland C 3.1
    By AZ1699 in forum C Programming
    Replies: 16
    Last Post: 11-16-2007, 10:22 AM
  2. Someone having same problem with Code Block?
    By ofayto in forum C++ Programming
    Replies: 1
    Last Post: 07-12-2007, 08:38 AM
  3. A question related to strcmp
    By meili100 in forum C++ Programming
    Replies: 6
    Last Post: 07-07-2007, 02:51 PM
  4. WS_POPUP, continuation of old problem
    By blurrymadness in forum Windows Programming
    Replies: 1
    Last Post: 04-20-2007, 06:54 PM
  5. beginner problem
    By The_Nymph in forum C Programming
    Replies: 4
    Last Post: 03-05-2002, 04:46 PM

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21